Last Comment Bug 706846 - Custom App updates not working on Linux with xulrunner > 1.9.0.17
: Custom App updates not working on Linux with xulrunner > 1.9.0.17
Status: RESOLVED INCOMPLETE
:
Product: Toolkit Graveyard
Classification: Graveyard
Component: XULRunner (show other bugs)
: 8 Branch
: x86_64 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-01 08:44 PST by Josh Nijenhuis
Modified: 2016-02-12 08:12 PST (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Josh Nijenhuis 2011-12-01 08:44:29 PST
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111114083844

Steps to reproduce:

Test Case:
We have our own custom app for xulrunner, we also have an update server setup for this app.
Updates don't want to work on Linux 32 or 64bit with any version of xulrunner 1.9.1 and above, 1.9.0.17 works perfectly.
Test scenario
downloaded the following runtimes from mozilla's ftp
xulrunner-1.9.0.17.en-US.linux-i686.tar
xulrunner-1.9.1.en-US.linux-i686.tar
xulrunner-8.0.1.en-US.linux-i686.tar
xulrunner-8.0.1.en-US.linux-x86_64.tar
xulrunner-9.0b3.en-US.linux-x86_64.tar

extracted and ran app for each one xulrunner version, the app updates with 1.9.0.17 but with every other one goes through the typical update process restarts the app and asks for the update again. All files have not been updated.

Downloading the same runtimes on Windows it works.
And on OS X it works also.


Actual results:

The update did not work with any xulrunner >1.9.0.17


Expected results:

The update should have gone through like it does on Windows and OS X and on xulrunner <1.9.1
Comment 1 Simon Kornblith 2011-12-21 19:41:25 PST
I had this problem. It turns out that the Linux updater expects to find icons/updater.png in your application directory. If it's not there, it dies.
Comment 2 William Vanderpol 2011-12-22 06:19:02 PST
Thanks Simon, our linux updates are working again!

Will add to wiki page https://developer.mozilla.org/en/XULRunner/Application_Update
Comment 3 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2016-02-12 07:17:38 PST
XULRunner has been removed from the Mozilla tree: see https://groups.google.com/forum/#!topic/mozilla.dev.platform/_rFMunG2Bgw for context.

I am closing all the bugs currently in the XULRunner bugzilla component, in preparation for moving this component to the graveyard. If this bug is still valid in a XULRunner-less world, it will need to be moved to a different bugzilla component to be reopened.

Note You need to log in before you can comment on or make changes to this bug.