Closed Bug 706860 Opened 11 years ago Closed 11 years ago

Opening a link in a new tab causes the current tab to resize

Categories

(Firefox for Android Graveyard :: General, defect, P1)

ARM
Android
defect

Tracking

(fennec11+)

VERIFIED WORKSFORME
Tracking Status
fennec 11+ ---

People

(Reporter: nhirata, Assigned: kats)

References

Details

Attachments

(1 file)

1. go to news.google.com
2. open a link in a new tab

Expected: no resize of current tab
Actual: resize of current tab

Note:
Build 20111201 ; Samsung Galaxy S II
bug 707272 may be a dup.  happens on any page.
Naoki, Doug says we fixed this in the last few days, please re-test
Priority: -- → P1
Just tested on Samsung Nexus S with build 20111208; This is fixed.
Duplicate of this bug: 707272
Duplicate of this bug: 707713
Duplicate of this bug: 707983
Duplicate of this bug: 708500
I should rephrase.  

- Opening a link in a new tab will not cause the current page to resize.  
- Opening a remote page link from a remote page in the same tab will cause the shrinking of the current remote page and resizing of the new remote page.
- using a local page would give you the results of bug 707935.
Duplicate of this bug: 708932
- opening a new tab in a current page with a view port will cause bug 708932.  I think bug 708932 might not be a dup of this bug.
This should have been fixed with https://hg.mozilla.org/mozilla-central/rev/e67d90275715 - I can't reproduce it on my Galaxy Tab. Could you please re-test?
Assignee: nobody → bugmail.mozilla
This seems to be fixed on today's nightly.  I can't reproduce the problem anymore.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
tracking-fennec: --- → 11+
I wasn't able to reproduce it.

verified on Nightly: Mozilla /5.0 (Android;Linux armv7l;rv:12.0a1) Gecko/20120123 Firefox/12.0a1 Fennec/12.0a1
and Aurora: Mozilla /5.0 (Android;Linux armv7l;rv:11.0a2) Gecko/20120123 Firefox/11.0a2 Fennec/11.0a2

Device: LG Optimus 2X (Android 2.2)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.