Status

www.mozilla.org
General
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Marilyn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
For mozilla.org/foundation/documents

Please put attachment under heading "2010 filings and related documents"
 - 2010 IRS Form 990 for the Mozilla Foundation
(Reporter)

Comment 1

6 years ago
The file was too large to attach so you willf ind it at the URL indicated above and here,too: http://kewbeach.ca/mozilla/Form 990 - 2010.pdf
(Assignee)

Updated

5 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
Added by r100426
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Duplicate of this bug: 721376
You need to log in before you can comment on or make changes to this bug.