Near-perma-orange: TEST-UNEXPECTED-FAIL | test-newmailaccount.js | test-newmailaccount.js::test_get_an_account

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: standard8, Assigned: mconley)

Tracking

({intermittent-failure})

Trunk
All
Windows XP
intermittent-failure

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
We've got a new near-permanent orange in comm-central:

TEST-START | e:\buildbot\comm-central-win32-opt-unittest-mozmill\build\mozmill\newmailaccount\test-newmailaccount.js | test_get_an_account
Step Pass: {"function": "controller.click()"}
Step Pass: {"function": "controller.waitFor()"}
Step Pass: {"function": "controller.waitFor()"}
Test Failure: waitFor: Timeout exceeded for 'function () $("#results").children().length > 0'
TEST-UNEXPECTED-FAIL | e:\buildbot\comm-central-win32-opt-unittest-mozmill\build\mozmill\newmailaccount\test-newmailaccount.js | test-newmailaccount.js::test_get_an_account
TEST-START | e:\buildbot\comm-central-win32-opt-unittest-mozmill\build\mozmill\newmailaccount\test-newmailaccount.js | teardownModule
TEST-PASS | e:\buildbot\comm-central-win32-opt-unittest-mozmill\build\mozmill\newmailaccount\test-newmailaccount.js | test-newmailaccount.js::teardownModule
INFO Passed: 2
INFO Failed: 1
INFO Skipped: 0
##### MOZMILL-RICH-FAILURES-BEGIN #####
...
##### MOZMILL-RICH-FAILURES-END #####
SUMMARY-PASS | test-newmailaccount.js::setupModule
SUMMARY-UNEXPECTED-FAIL | e:\buildbot\comm-central-win32-opt-unittest-mozmill\build\mozmill\newmailaccount\test-newmailaccount.js | test-newmailaccount.js::test_get_an_account
  EXCEPTION: waitFor: Timeout exceeded for 'function () $("#results").children().length > 0'
    at: utils.js line 429
       TimeoutError("waitFor: Timeout exceeded for 'function () $(\"#results\").children().length > 0'") utils.js 429
       waitFor((function () $("#results").children().length > 0),"waitFor: Timeout exceeded for 'function () $(\"#results\").children().length > 0'",5000,100,(void 0)) utils.js 467
            controller.js 648
       test_get_an_account() test-newmailaccount.js 126
            frame.js 557
            frame.js 626
            frame.js 669
            frame.js 497
            frame.js 675
            server.js 179
            server.js 183
SUMMARY-PASS | test-newmailaccount.js::teardownModule

Seemed to start around:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1900e3edd32d&tochange=66a1db693790

Only really seen on windows so far.

Mike, can you take a look please?
(Reporter)

Updated

7 years ago
Whiteboard: [tb-orange]
(Assignee)

Comment 1

7 years ago
Sure, on it.
(Assignee)

Comment 2

7 years ago
So far, I've been unable to reproduce this locally.

I'm going to push my account provisioner polish patch to try (which modifies the account provisioner tests somewhat, since the window becomes modal) to see if that clears the issue.

Try builds arriving here:  http://build.mozillamessaging.com/tinderboxpushlog/?tree=ThunderbirdTry&rev=00afc59a988f
(Assignee)

Comment 3

7 years ago
Having seen the Windows try builds of my patch for bug 700536, I think that patch will fix this orange.

Fingers crossed, anyhow.
(Assignee)

Comment 4

7 years ago
I'm pretty confident this got fixed when the patch for bug 700536 landed.  Closing for now.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Keywords: intermittent-failure
Whiteboard: [tb-orange]
You need to log in before you can comment on or make changes to this bug.