Not possible to drag and drop across multiple dashboard screens

RESOLVED INVALID

Status

P3
normal
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: igarcia, Unassigned)

Tracking

Details

(Whiteboard: [testday-20111202])

(Reporter)

Description

7 years ago
When moving apps across multiple screens in https://myapps.mozillalabs.com/ it's not possible (or at least not in a simple way) to move the icon more than one screen at a time.

In other words, when pressing and holding the Gmail app and moving it from the first to the second screen, it's not possible to move it to the third screen without dropping it in the second screen first.

This may be critical when screens get completely filled.

Comment 1

7 years ago
Confirmed with Mozilla/5.0 (X11; Linux x86_64; rv:9.0) Gecko/20100101 Firefox/9.0: the app's icon "falls" near the farther border of the second screen.
OS: Mac OS X → All
Whiteboard: [testday-20111202]

Comment 2

7 years ago
If you pull your cursor outside the boundaries of the grid, then yes, this is the behavior that happens.  It cannot be prevented, as we lose mouse focus.  Drag the icon to the edge of the grid, but keep your cursor in bounds, and you can drag across as many pages as you like.
Priority: -- → P3
Intended behavior.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 4

7 years ago
I believe what the reporter is referring to is that you can only drag an icon one panel to the left or the right and you cannot drag it to multiple panels at the same time. They are able to drag an icon to another panel, but they can only drag it to the next or previous one. So for example, if the icon is in the first panel and they wanted to drag it to the third panel, they have to drag it to the second, drop the icon, then grab it again and then move it to the third. They want to be able to drag it to the third without having to drop the icon in the second.
You need to log in before you can comment on or make changes to this bug.