Web API: Gallaxy SII fails Vibrate Demos

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: arky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:11.0a1) Gecko/20111130 Firefox/11.0a1
Build ID: 20111130034254

Steps to reproduce:

Tested my Gallaxy SII running latest nativeUI trunk with 
http://people.mozilla.org/~jhammink/webapi_test_pages 

It fails to all the Vibrate Demos

Updated

6 years ago
OS: Linux → Android
Hardware: x86 → ARM

Comment 1

6 years ago
I am also unable to get it to work on any of my android devices. Latest Native Nightly (12/6)   

Filed https://bugzilla.mozilla.org/show_bug.cgi?id=708172 which, I now see, is a dupe.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Duplicate of this bug: 708172
We haven't landed the DOM API.  Note that bug 679966 has not been closed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
If you load up logcat and visit the page, you get

E/GeckoConsole(18009): [JavaScript Error: "navigator.mozVibrate is not a function" {file: "http://people.mozilla.org/~jhammink/webapi_test_pages/VibratorAPIdemo.html" line: 8}]

as expected.

Comment 5

6 years ago
Ahh, sorry :) it must have been the case that I had this working before with some special build.
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: INVALID → ---

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.