Starting Fennec up via commandline using an nonexisting local web page will crash Fennec

RESOLVED WORKSFORME

Status

()

P4
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash], reproducible)

1. install the latest nightly
2. do an adb shell
3. run command : 
am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App -d file://mnt/sdcard/download/twitter/toptweets/favorites.html

Expected: file does not exist error
Actual: crash
note: 20111202, Samsung S II, Android OS 2.3
I/GeckoTabs( 8469): Added a tab with id: 1, url: file://mnt/sdcard/download/twitter/toptweets/favorites.html
E/GeckoConsole( 8469): [JavaScript Error: "uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIWebNavigation.loadURI]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: <unknown filename> :: loadURIWithFlags :: line 193"  data: no]"]
E/GeckoConsole( 8469): OverlayManager: Creating window entry for chrome://browser/content/browser.xul
I/Gecko   ( 8469): ***  LOG  *** OverlayManager: Creating window entry for chrome://browser/content/browser.xul
E/GeckoConsole( 8469): OverlayManager: Loading script overlay chrome://testharness/content/overlay.js
I/Gecko   ( 8469): ***  LOG  *** OverlayManager: Loading script overlay chrome://testharness/content/overlay.js
I/Gecko   ( 8469): nsWindow::GetLayerManager
I/Gecko   ( 8469): Extensions: EGL_KHR_image EGL_KHR_image_base EGL_KHR_image_pixmap EGL_ANDROID_image_native_buffer EGL_ANDROID_swap_rectangle  0x45
I/Gecko   ( 8469): Extensions length: 113
I/Gecko   ( 8469):  -- creating basic, not accelerated
E/GeckoConsole( 8469): [JavaScript Error: "this.selectedTab is null" {file: "chrome://browser/content/browser.js" line: 529}]
E/GeckoSoftwareLayerClient( 8469): Bad viewport description: 
W/System.err( 8469): java.lang.RuntimeException: org.json.JSONException: End of input at character 0 of 
W/System.err( 8469): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.updateViewport(GeckoSoftwareLayerClient.java:159)
W/System.err( 8469): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.endDrawing(GeckoSoftwareLayerClient.java:169)
W/System.err( 8469): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
W/System.err( 8469): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
W/System.err( 8469): 	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:452)
W/System.err( 8469): 	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:118)
W/System.err( 8469): Caused by: org.json.JSONException: End of input at character 0 of 
W/System.err( 8469): 	at org.json.JSONTokener.syntaxError(JSONTokener.java:446)
W/System.err( 8469): 	at org.json.JSONTokener.nextValue(JSONTokener.java:93)
W/System.err( 8469): 	at org.json.JSONObject.<init>(JSONObject.java:154)
W/System.err( 8469): 	at org.json.JSONObject.<init>(JSONObject.java:171)
W/System.err( 8469): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.updateViewport(GeckoSoftwareLayerClient.java:132)
W/System.err( 8469): 	... 5 more
E/GeckoConsole( 8469): [JavaScript Error: "browser is null" {file: "chrome://browser/content/browser.js" line: 1180}]
I/GeckoApp( 8469): Got message: Content:SecurityChange
I/GeckoApp( 8469): Security Mode - unknown
E/GeckoConsole( 8469): [JavaScript Error: "browser is null" {file: "chrome://browser/content/browser.js" line: 1180}]
I/GeckoApp( 8469): Got message: Content:SecurityChange
I/GeckoApp( 8469): Security Mode - unknown
I/GeckoDoorHangerPopup( 8469): Showing all doorhangers for tab: 1
D/GeckoInputConnection( 8469): IME: run()
D/GeckoInputConnection( 8469): IME: v=org.mozilla.gecko.gfx.LayerView@4058f618
I/dalvikvm( 8469): Total arena pages for JIT: 11
Priority: -- → P4
Crash doesn't seem to occur anymore with the STR.  There's another bug in regards to the File Not found page that pops up.  Will report that separately.

2012/01/26
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.