New tab is not shown at times, while switching from about:home

VERIFIED FIXED

Status

()

VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: sriram, Assigned: sriram)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

7 years ago
When fennec is loaded and adding a new tab with google.com, the new tab is not shown. Only a grey background is shown.
(Assignee)

Comment 1

7 years ago
The problem is with hiding the visibility of mLayerController. View.GONE makes it shrink to 0x0. Switching tabs, the viewport is small, and things get crazy.

This can be solved by replacing the AbsoluteLayout with RelativeLayout and stacking the Views on top it.

The lowermost layer will the mLayerController. The plugins (flash content) should be placed on top of them in a separate layer. The about:home will be on top of it.

This way, when user navigates to about:home, the about:home is just shown on hidden. The size of the mLayerController remains unchanged.
(Assignee)

Comment 2

7 years ago
Created attachment 578730 [details]
WIP

This WIP moves the replaces the AbsoluteLayout with RelativeLayout.
I feel the about:home layout needs to be cleaned a bit. There is a LinearLayout inside a LinearLayout -- which is not needed.
A new RelativeLayout needs to be added to hold the plugins (flash) content.
A more better patch will be added after making those changes.
(Assignee)

Comment 3

7 years ago
Created attachment 578756 [details] [diff] [review]
Patch

This patch creates different "containers" (layers) for different contents, as specified. The flash works fine. The AboutHome is cleared too.
Attachment #578756 - Flags: review?(pwalton)
Attachment #578756 - Flags: review?(mark.finkle)

Updated

7 years ago
Assignee: nobody → sriram
Status: NEW → ASSIGNED
Comment on attachment 578756 [details] [diff] [review]
Patch

Review of attachment 578756 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, but mfinkle should review this as well, since he knows the chrome UI better than I do.
Attachment #578756 - Flags: review?(pwalton) → review+
Comment on attachment 578756 [details] [diff] [review]
Patch

These changes look good to me and don't seem to regress plugins.
Attachment #578756 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/projects/birch/rev/a7fb88bd5148
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
verified fixed on:
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111206 Firefox/11.0a1 Fennec/11.0a1 - Native Fennec build
Device: Samsung GalaxyS, Android 2.2
Status: RESOLVED → VERIFIED

Updated

7 years ago
No longer depends on: 711184
You need to log in before you can comment on or make changes to this bug.