If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cached online calendars cause extreme delay and frozen mail UI at startup

RESOLVED DUPLICATE of bug 412914

Status

Calendar
General
RESOLVED DUPLICATE of bug 412914
6 years ago
6 years ago

People

(Reporter: Ronan Jouchet, Unassigned)

Tracking

Lightning 1.0

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111124194126

Steps to reproduce:

1. Set up a few online calendars (e.g. http://www.google.com/calendar/ical/4b3vms6i8vm26lvg69d7ncobec%40group.calendar.google.com/public/basic.ics )
2. Check the 'cache' option in their properties
3. Restart Thunderbird


Actual results:

- High hard drive load
- Thunderbird's UI froze (nothing was clickable) during calendar refresh.

I have 6 online calendars, the impact in seconds for each one (in seconds) is: 2, 12, 15, 50, 3, 5, totalling a minute and a half to be able to read email. The 50seconds badass calendar is the one mentioned above


Expected results:

Thunderbird should start as quickly as usual, or maybe with a small delay. If caching requires sync at startup, maybe it could be done in a way that doesn't impact the usability of the whole mail client (use a different thread?)

Note: I'm positive my bug is due to the "cache" feature: unchecking the cache for each calendar results in a Tb starting up as fast as expected.
(Reporter)

Comment 1

6 years ago
Debug info:

Hardware: a recent Dell laptop with an okay HD and 8 cores
OS: Ubuntu 11.10 x86
FS: Ext4
Thunderbird: 8.0
Lightning: 1.0

Comment 2

6 years ago
Adding Mohit as he developed the offline mode.

Does this just happen with the ICS Provider? Happens the same with the CalDAV provider? 

Could you attach teh calendar.debug.

Thanks

Comment 3

6 years ago
Known problem. There is a patch waiting for review in Bug 412914 that might help.

Comment 4

6 years ago
Thanks Stefan! This is exactly the same and therefore a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 412914
You need to log in before you can comment on or make changes to this bug.