multiple tabs open and restart of Firefox prompt does not identify tab

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: grgoffe, Unassigned)

Tracking

9 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupeme?)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111130065942

Steps to reproduce:

After a system crash, I restarted Firefox and got all my previous tabs opening.


Actual results:

During this multiple tab opening I got a prompt warning me that a tab was going to "refresh" which would reissue any orders or changes or other activities. There was NO indication as to which tab was doing this. I had about 90 open. I got lucky since I had been making bug reports and got several "mid-air collisions". If I had been ordering things, I might now have multiple orders flying around.


Expected results:

The prompt needs to say which tab and perhaps switch to the tab in question so the user can make a more well informed decision to redo the request or cancel it or maybe more options?
(Reporter)

Comment 1

7 years ago
A simple kill of the Firefox processes with multiple tabs open to perhaps making bug reports ought to re-create the bug. I have the session manager add-on installed.

Comment 2

6 years ago
George, do you still see this problem?
Summary: multiple tabs open and restart of Firefox prompt → multiple tabs open and restart of Firefox prompt does not identify tab
Whiteboard: dupeme?
(Reporter)

Comment 3

6 years ago
Wayne,

Not for some time. I'm on 17 of Nightly.

George...

Comment 4

5 years ago
See comment 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.