Closed Bug 707526 Opened 10 years ago Closed 10 years ago

FireFox (8.0.1) on OSX 10.7.2 concludes that QuickTime plugin needs additional plugins to play an mp4 file

Categories

(Core :: Plug-ins, defect)

8 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 670036

People

(Reporter: avk, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:8.0.1) Gecko/20100101 Firefox/8.0.1
Build ID: 20111120135848

Steps to reproduce:

Play a mp4 files. In its simplist form. Just a link to a stored .mp4 on a webserver  


Actual results:

FireFox 8.0.1 on OSX 10.7.2 concludes I need a quicktime extension to play the sound, while the application setting shows that a mp4 file is played by quicktime while the same FF version on a XP system does play the file.
Chrome, Safari and Opera are all capable of playing that file with QuickTime on OSX 1.7.2


Expected results:

It should play the file as the mime type is properly communicated and the file is completely loaded. Other file types like .mov are properly played.
Component: General → Plug-ins
QA Contact: general → plugins
This is probably a dup of bug 670036, which was fixed by the patch for bug 687610.

This patch in current (9.0 branch) betas, and in current aurora and mozilla-central nightlies.  It *isn't* in FF 8.0 or 8.0.1, but will be in FF 9.

The workaround is to empty your network cache before loading (or especially reloading) any QuickTime media.  Or use Command-Shift-r to reload the page that contains the media.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 670036
You need to log in before you can comment on or make changes to this bug.