[SeaMonkey] "browser_bug435325.js:15 - ReferenceError: gPrefService is not defined"

VERIFIED FIXED in Firefox 11

Status

()

Core
Document Navigation
--
major
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: sgautherie, Assigned: Steffen Wilberg)

Tracking

(Blocks: 2 bugs)

Trunk
mozilla12
x86_64
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox10 wontfix, firefox11 verified, firefox-esr10 affected)

Details

(Whiteboard: [perma-orange], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1323030901.1323034450.12769.gz
OS X 10.6 comm-central-trunk debug test mochitest-other on 2011/12/04 12:35:01
{
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/docshell/test/browser/browser_bug435325.js | Exception thrown at chrome://mochitests/content/browser/docshell/test/browser/browser_bug435325.js:15 - ReferenceError: gPrefService is not defined

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/docshell/test/browser/browser_bug435325.js | Cleanup function threw an exception at chrome://mochitests/content/browser/docshell/test/browser/browser_bug435325.js:45 - ReferenceError: gPrefService is not defined
}

Comment 1

6 years ago
Please use Services.prefs instead of gPrefService.
I don't see why Firefox is using a lazy getter here since Services.prefs is already a lazy getter. It can't get any lazier.
(Assignee)

Comment 2

5 years ago
Created attachment 584555 [details] [diff] [review]
patch [Checkin: Comments 6 and 12]

Worth a try.
Assignee: nobody → steffen.wilberg
Status: NEW → ASSIGNED
Attachment #584555 - Flags: review?(bzbarsky)
(Assignee)

Comment 3

5 years ago
Looks like SeaMonkey doesn't define gPrefService globally like http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#134 does.

The test still passes locally.
Comment on attachment 584555 [details] [diff] [review]
patch [Checkin: Comments 6 and 12]

r=me
Attachment #584555 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 5

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/66b79f9ae14f
Target Milestone: --- → mozilla12
https://hg.mozilla.org/mozilla-central/rev/66b79f9ae14f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

5 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1325307514.1325311688.15214.gz&fulltext=1
OS X 10.6 comm-central-trunk debug test mochitest-other on 2011/12/30 20:58:34
{
[...]
TEST-PASS | [...]
INFO TEST-END | chrome://mochitests/content/browser/docshell/test/browser/browser_bug435325.js | finished in 963ms
}

V.Fixed
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
(Reporter)

Comment 8

5 years ago
Comment on attachment 584555 [details] [diff] [review]
patch [Checkin: Comments 6 and 12]

[Approval Request Comment]
Regression caused by (bug #): bug 435325
User impact if declined: none
Testing completed (on m-c, etc.): yes, comment 7
Risk to taking this patch (and alternatives if risky): no risk, test-only

This fixes a test and might (additionally) help with bug 699684 comment 3.
Attachment #584555 - Flags: approval-mozilla-beta?
Attachment #584555 - Flags: approval-mozilla-aurora?

Comment 9

5 years ago
Comment on attachment 584555 [details] [diff] [review]
patch [Checkin: Comments 6 and 12]

[Triage Comment]
Test-only fix - approved for aurora/beta.
Attachment #584555 - Flags: approval-mozilla-beta?
Attachment #584555 - Flags: approval-mozilla-beta+
Attachment #584555 - Flags: approval-mozilla-aurora?
Attachment #584555 - Flags: approval-mozilla-aurora+
(Reporter)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: [perma-orange] → [c-n: to m-a and m-b] [perma-orange]
Adjusting whiteboard post uplift.
(I don't have a beta tree, or I'd check it in)
Whiteboard: [c-n: to m-a and m-b] [perma-orange] → [c-n: to mozilla-beta] [perma-orange]
(Reporter)

Updated

5 years ago
status-firefox10: --- → wontfix
(Assignee)

Comment 11

5 years ago
Aurora (v12), by uplift from mozilla-central:
https://hg.mozilla.org/releases/mozilla-aurora/rev/66b79f9ae14f

Still needs to land on mozilla-beta (v11).
status-firefox11: --- → affected
status-firefox12: --- → fixed
(Reporter)

Updated

5 years ago
status-firefox-esr10: --- → affected
Comment on attachment 584555 [details] [diff] [review]
patch [Checkin: Comments 6 and 12]

http://hg.mozilla.org/releases/mozilla-beta/rev/7af76ad904df
Attachment #584555 - Attachment description: patch → patch [Checkin: Comments 6 and 12]
status-firefox11: affected → fixed
Keywords: checkin-needed
Whiteboard: [c-n: to mozilla-beta] [perma-orange] → [perma-orange]
(Reporter)

Comment 13

5 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Beta/1330216750.1330220892.12201.gz
OS X 10.5 comm-beta debug test mochitest-other on 2012/02/25 16:39:10

firefox11: verified.
status-firefox11: fixed → verified
status-firefox12: fixed → ---
(Reporter)

Updated

5 years ago
Blocks: 699684
You need to log in before you can comment on or make changes to this bug.