Last Comment Bug 707654 - embeds relation on root accessible can return not content document
: embeds relation on root accessible can return not content document
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: alexander :surkov
:
: alexander :surkov
Mentors:
Depends on: 720393 725647
Blocks: rela11y
  Show dependency treegraph
 
Reported: 2011-12-05 06:19 PST by alexander :surkov
Modified: 2012-02-09 07:00 PST (History)
4 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (11.94 KB, patch)
2011-12-05 06:27 PST, alexander :surkov
dbolter: review+
Details | Diff | Splinter Review

Description alexander :surkov 2011-12-05 06:19:13 PST
For example, if you install Firebug extension then it adds extra document accessible that is returned by embeds relation but the tab document is expected.
Comment 1 alexander :surkov 2011-12-05 06:27:27 PST
Created attachment 579054 [details] [diff] [review]
patch
Comment 2 Phil Ringnalda (:philor) 2012-01-22 18:12:15 PST
https://hg.mozilla.org/mozilla-central/rev/ca7d87ab38b6
Comment 3 Ed Morley [:emorley] 2012-01-23 10:01:29 PST
MarcoZ asked if this could be backed for now due to bug 720393, hope this was ok :-)

https://hg.mozilla.org/mozilla-central/rev/9b069a37f58f
Comment 4 alexander :surkov 2012-01-30 01:41:57 PST
I'm surprised that this bug caused bug 720393 because Jamie said embed relations are used for plugin stuffs only so it shouldn't lead to issues observed in bug 720393. Moreover I don't see any changes in behavior (at least prior to bug 591363 which broke it).

I pushed try server build https://tbpl.mozilla.org/?tree=Try&rev=9c9d74894bca. Marco, when it's ready please try it.
Comment 6 Marco Zehe (:MarcoZ) 2012-01-30 01:50:28 PST
Well, the observation is completely confirmed: I had the issues with this bug in, with it backed out, the situation returned to normal. There were two nightlies built on that day, the first with, the second without the patch after I identified it as being the guilty part. So the backout definitely fixed it.
Comment 7 James Teh [:Jamie] 2012-01-30 03:44:36 PST
I'm also seeing situations where the first tab document is returned, even if another tab is active. Is this related or should I file another bug?
Comment 8 alexander :surkov 2012-01-30 17:39:16 PST
(In reply to James Teh [:Jamie] from comment #7)
> I'm also seeing situations where the first tab document is returned, even if
> another tab is active. Is this related or should I file another bug?

for the record: as I said on irc it's regression from bug 591363.
Comment 9 James Teh [:Jamie] 2012-01-30 18:11:33 PST
(In reply to alexander :surkov from comment #8)
> > I'm also seeing situations where the first tab document is returned, even if
> > another tab is active.
> for the record: as I said on irc it's regression from bug 591363.
I can confirm this is fixed by this patch.

Marco, I can't reproduce bug 720393 with this try build. I tried with the NVDA Snapshots page (which contains an iframe):
http://www.nvda-project.org/snapshots/
I moved to one of the download links within the iframe. I also tried Gmail and couldn't reproduce it their either. Scarily enough, I can't think of any pages with Facebook or Twitter gadgets on them right now (even though I see them all the time), so haven't tested that yet.
Comment 10 Marco Zehe (:MarcoZ) 2012-01-30 22:17:01 PST
Strange, I did see it with every try in that short-lived nightly build, and that was, indeed, the only patch that landed. And it had to be a focused item inside. A difference may be that here, there's a lot of test and stuff that comes before the first focusable item, whereas with Twitter widgets the focusable item comes first thing inside those iframes.
Comment 11 alexander :surkov 2012-01-30 22:18:46 PST
Marco, do you see any problems with try server build?
Comment 12 Marco Zehe (:MarcoZ) 2012-01-30 22:27:01 PST
(In reply to alexander :surkov from comment #11)
> Marco, do you see any problems with try server build?

No, this latest try-server build is fine.
Comment 13 alexander :surkov 2012-01-30 22:34:02 PST
Ok, I'll land it then again
Comment 15 Ed Morley [:emorley] 2012-01-31 08:54:43 PST
https://hg.mozilla.org/mozilla-central/rev/c75743aa5bce

Note You need to log in before you can comment on or make changes to this bug.