If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When sending email, Thunderbird adds a space character to lines starting with whitespace

RESOLVED DUPLICATE of bug 608514

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 608514
6 years ago
6 years ago

People

(Reporter: Christian, Unassigned)

Tracking

8 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111108090024

Steps to reproduce:

I use plain-text email, and I often compose messages that have bullet points, like this one:

- Here's a bullet point that I manually
  indent in subsequent lines to line up.


Actual results:

Thunderbird decides to tuck an additional space character on to the lines already starting with whitespace. So basically, what I sent like this ...

-<spc>Here's a bullet point that I manually
<spc><spc>indent in subsequent lines to line up.

... turns into this, in both the sent message and the corresponding received one:

-<spc>Here's a bullet point that I manually
<spc><spc><spc>indent in subsequent lines to line up.



Expected results:

Thunderbird should keep my line-start whitespace as I intended it.

Comment 1

6 years ago
See bug 608514 which seems to apply here, i.e., in plain-text composition mode and without format=flowed disabled, this should be the standard-compliant encoding.

Some e-mail clients (like Outlook) ignore format-flowed and show the leading space as is present in the encoding, though they are not supposed to.

In Edit > Preferences > Advanced > General > Config Editor, toggle the preference mailnews.send_plaintext_flowed to "false" and you should see the space removed.

Thunderbird displays either encoding (with or without flowed format) as expected.
Whiteboard: dupeme
(Reporter)

Comment 2

6 years ago
Thanks, you're right regarding the adjustment to mailnews.send_plaintext_flowed, it helped.

I suppose when you say "as expected" you mean the extra space is expected when send_plaintext_flowed is true, because I do see the extra space both in sent and received messages in Thunderbird.

Comment 3

6 years ago
Yes, the display in Thunderbird itself is correct with the leading space removed. Since there doesn't seem to be a bug, I'm closing this report as a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 608514

Updated

6 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.