Closed Bug 707906 Opened 8 years ago Closed 7 years ago

Dock the Style Editor

Categories

(DevTools :: Style Editor, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 788977
Firefox 13

People

(Reporter: cedricv, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(2 files, 2 obsolete files)

No description provided.
Blocks: 687702
Attached image sidebars position
I believe that this should a more generic feature. We also want this for the scratchpad and any future "page centric" tools.

This tool is a "page centric" tool. It is not related to the inspector. So it should not live in Inspector UI (node centric tools).

Here is how I see it:

1) a "page centric" tool can live in a horizontal sidebar, vertical sidebar or in a window.

2) Firefox should be able to stack "page centric" tools next to each other (not just one sidebar placeholder). For example, we should be able to have, at the same time, the scratchpad and the style editor in 2 vertical sidebars (I'm not saying we should have this layout by default, but I think it has to be possible).

3) Sidebars (vertical or horizontal) should be created dynamically. Each tool should live in an iframe. Moving the iframe from a vertical sidebar to a horizontal sidebar, or to a window, should be seamless for the user.
Summary: Dock the Style Editor within the Inspector UI → Dock the Style Editor
Depends on: 708214
No longer blocks: 687702
filter on pegasus.
Target Milestone: --- → Firefox 13
Depends on: 717944
Attached patch v0.1 - WIP (obsolete) — Splinter Review
Attached patch v0.2 (obsolete) — Splinter Review
Attachment #636318 - Attachment is obsolete: true
Attached patch v0.999Splinter Review
Attachment #636465 - Attachment is obsolete: true
Depends on: 768229
This works pretty well. But bug 768229 needs to be fixed first before going further.
Depends on: 768442
Blocks: 771203
Blocks: 782593
Depends on: 801560
Fixed with Toolbox.

Bug triage, filter on PINKISBEAUTIFUL
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 788977
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.