seb.se - Sweden's largest bank doesn't let in Mozilla.

VERIFIED FIXED in Jan

Status

Tech Evangelism Graveyard
Other
P1
normal
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: André Dahlqvist, Assigned: Tristan Nitot)

Tracking

unspecified
x86
All

Details

(Whiteboard: [BANKING][USERAGENT][DENY], URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2 i586; en-US; 0.9) Gecko/20010303
BuildID:    2001030221

The bank on the mentioned URL does not let you log in with Mozilla. Instead you
are re-directed to a page which tells you that you need IE 4.01 or Netscape 4.08
to use their system.

Reproducible: Always

Steps to Reproduce:

1) Go to the URL http://www.seb.se
2) Choose "Privat" in the listbox to the right.

Actual Results:  You will be directed to a site saying you need IE 4.01 or
Netscape 4.08 to use their system.

Expected Results:  The bank should show me the login screen allowing me to log
in to their system.

This is Sweden's largest bank, so they really ought to support web standards.

Comment 1

17 years ago
I could not reproduce this bug.  I believe the web site has changed since this
bug was written.   Could the reporter or owner also please verify.  Thanks

Comment 2

17 years ago
OK I take it back, I found the right place.

Go to the login popup window(upper left) and select private.  I'm on it....
(Reporter)

Comment 3

17 years ago
petitta@netscape.com, sorry for the messup in the instructions, that 'right'
should of course have been 'left'. I'm glad to see you're on this. I've mailed
them myself in the past, and they have responded that they have not yet tested
their site with Mozilla nor Netscape 6, and therefore doesn't support it. I
brought it up with them the first time at least 6 months ago, so they have had
plenty of time to deal with it.

Getting an e-mail from someone with a @netscape.com address should probably help
I hope:-)

Comment 4

17 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary
(Reporter)

Comment 5

17 years ago
Has anyone from netscape contacted the bank? If so, did they respond?
(Reporter)

Comment 6

17 years ago
I contacted the bank again yesterday, and now they gave a rather positive answer:

"You're right. The work of getting Netscpae 6 functioning with our service has
taken much too long. It will work soon."

I used Netscape 6 instead of Mozilla in my e-mail, because I didn't want to
confuse them too much.

Comment 7

17 years ago
Still won't let us in ... Accepting bug since they have been contacted already.
Andre, I may ask you to send them another letter. You can tell them they can
contact me if they like.
Status: NEW → ASSIGNED
Whiteboard: [BANKING][USERAGENT][DENY]
(Reporter)

Comment 8

17 years ago
Bob, I just sent off another e-mail to their support staff, and asked them to
forward my e-mail to the technical people working with this. I also told them
that they could contact either you or me if they needed further assistance with
this. I'll add another comment as soon as they respond.

Comment 9

17 years ago
Assigning to Euro Evangelist
Assignee: bclary → nitot
Status: ASSIGNED → NEW

Comment 10

17 years ago
giving qa to kat
QA Contact: zach → momoi

Comment 11

17 years ago
This is still happening today, with Mozilla 2001062306 Linux.

Comment 12

17 years ago
The site is running:

Stronghold/2.4.1 Apache/1.3.3 C2NetEU/2409 (Unix)

While the version is slightly higher than Stroghold/2.2
for which there is a known TLS/SSL3.0 rollback problem,
I am not sure if this newer version has the same problem.
Tristan, please call them and talk to someone in the 
operations.

Contact info on this page:

https://disp.sebank.se/cgi-bin/ptslogin/WOW/wo10.c1001.f001
Priority to P1.
Priority: -- → P1
(Reporter)

Comment 13

17 years ago
The number to call when calling from abroad is +46 771 24 11 11. (That's what it
says in Swedish on that page.)
(Reporter)

Comment 14

17 years ago
Has anyone had a chance to call the bank yet?
(Reporter)

Comment 15

17 years ago
This bank has something called "direct payment" which means that if you visit an
online seller of some sort that supports this bank I can directly choose to be
redirected to the bank and pay the bill there. When you do this with mozilla you
can in fact login. The login page when you do this looks exactly like the login
page you never reach with Mozilla when you choose "Privat" from the main page.

I just sent of yet another e-mail to the support staff of this bank.

Comment 16

17 years ago
Tristan, this seems to be Sweden's largest bank.
Can you contact them to find out what is taking so 
long to deal with NS6/Mozilla? If it is a TLS issue,
you might want to tell them that the next Netscape release
and Mozilla 0.9.3 can gacefully roll back to SSL3 
even if the server side has a TLS rollback porblem.

Updated

17 years ago
Component: Evangelism → European
Product: Browser → Tech Evangelism
Version: other → unspecified
(Reporter)

Comment 17

17 years ago
I was contacted by another customer of this bank and he had been given roughly
this explanation by the bank:

"Unfortunately our internet service is not yet adapted for Mozilla. The biggest
problem is the loading of the navigation menu. What happens is that the entire
menu "melts together" and what is displayed is a big grey box. Currently we do
not have many technicians working on solving this problem since we do not yet
know what will come of the merger with Föreningssparbanken" (another swedish bank).

This sounds like they have used some IE or Netscape-specific tags in their HTML,
right? Below I will attach a screenshot of how this navigation menu looks in 4.7. 

It sounds like they are willing to fix this if they just knew how. Can someone
from Netscape please push them in the right direction?
(Reporter)

Comment 18

17 years ago
Created attachment 47510 [details]
Screenshot of how the navigation menu looks in 4.7. This doesn't work in Mozilla according to them.
(Reporter)

Comment 19

17 years ago
I sent of another mail to the bank asking about the status of this. They 
responded that they are now working with Netscape on this and a solution seams 
close. They expect it to be fixed within some weeks.

So Tristen, are they working with you on this?

Comment 20

17 years ago
Moving to new component West Europe.  European is being removed.  See bug 95808
for details.
Component: European → West Europe
QA Contact: momoi → caillon
Summary: Sweden's largest bank doesn't let in Mozilla. → seb.se - Sweden's largest bank doesn't let in Mozilla.
(Reporter)

Comment 21

16 years ago
I don't want to sound like a pain in the ass, but is the banks statement true
that you guys are working with them?
(Assignee)

Comment 22

16 years ago
André,

Thank you for insisting. I have searched for seb.se and sebank.se bugs inside 
and outside the Netscape firewall, and none was reported except this one.

If they speak with one of us, I don't know who it is.

I'll try to contact them by monday.

Accepting bug. I can reproduce on Netscape 6.1RTM on Win2K. Setting OS : ALL.
Status: NEW → ASSIGNED
OS: Linux → All
(Reporter)

Comment 23

16 years ago
Tristan, thanks for taking on this bug. I guess I'm stating the obvious, but
remember to call them up rather early your time, since Sweden is CET + 2 hours.
The internet banking support department is open until 11 in the evening, but I
wouldn't expect that any of the technical people are there after 4 or 5.
(Reporter)

Comment 24

16 years ago
Tristen, this is still a problem. Can you try to find the cycles to make that call?
(Assignee)

Comment 25

16 years ago
Tried to reach the bank with no success.
(Reporter)

Comment 26

16 years ago
I guess the time difference is the problem, assuming it was closed when you
called them.

Comment 27

16 years ago
I also have been in contact with the bank before about this. When I now found
this bug, I mailed the link to them, asking them to review it and contact either
here, or in mail to bugowner.
(Reporter)

Comment 28

16 years ago
I've been poking on them again, and now they really seam to be working on this.
Here is the answer (translated by me) I have gotten after constant nagging:

"On friday Netscape 6.2 (the latest) will reach acceptance test, and after that
it will be tested 3-4 weeks. In other words we hope that it will come out in
production in the middle of december. We will not support the webbrowser Mozilla
0.9.3, that is a business decision."

The last sentance of course shows that they have not quiet understood the
relation ship between Netscape and Mozilla, and I would very much appreciate if
someone from Netscape could evangelize them on this. Will they even be able to
block Mozilla and accept Netscape 6.2?

Comment 29

16 years ago
In case anyone is curious on how the site looks with mozilla the following URL

could be of interest: http://www.lysator.liu.se/~cosis/seb.html



Of course you'll need to be a customer at the bank to make any use of it.
(Reporter)

Comment 30

16 years ago
Just to clarify: the URL that Martin mentions is his own webpage that enables
you to get around the bank's browser-sniffing. It is of course not something
that should be necessary.
(Assignee)

Comment 31

16 years ago
Contact info may be found in there : 
http://swp2.vv.sebank.se/cgi-bin/pts3/pow/kundservice/IntresseFormular_frm.asp
Waiting from Glazman to give me the right one (too many listed)
(Reporter)

Comment 32

16 years ago
Tristan, that's a bad way for you to reach them since you would be tossed
between many people before you got the right person

I have finally gotten a contact person there who is actually in charge of this
(the person is "chief architect" for their e-banking). The person e-mailed me
and asked me if mozilla and Netscape 6.x were 100% in respect to how they
rendered pages, and I answered that that was the case. I can send you this
persons e-mail address in private Tristan if you want it.
(Reporter)

Comment 33

16 years ago
100% compatible was of course what I was referring to.
(Assignee)

Comment 34

16 years ago
General contact info is internetredaktionen@seb.se
André : please send me in private the person nmae and e-mail details, so I can
contact them (nitot@netscape.com)

Thanks !
(Reporter)

Comment 35

16 years ago
Good news from the bank - starting from the 17th of December they will let
Mozilla and Netscape 6.2 in to their bank service.

Comment 36

16 years ago
As of today, 20011219, they still don't let Mozilla (ID 2001121803) in. The
"Actual Results" as described in this bug, still happens.
(Reporter)

Comment 37

16 years ago
Sorry, I have forgotten to send in the update that they sent me by e-mail.

They were to launch the new version of their internet banking on the 17th of
december, and mozilla support was supposed to be part of this update.
Unfortunately, the introduction of this new version has been posponed until the
middle of January, so the mozilla support has to wait too.

There are however some good news too: they will list mozilla on their page of
browsers that they officially support!
(Assignee)

Comment 38

16 years ago
André: these are great news!
Setting target to January.
Target Milestone: --- → Jan

Comment 39

16 years ago
Keep the good work up, André!
(Reporter)

Comment 40

16 years ago
Good news folks: they now let us in!
(Reporter)

Comment 41

16 years ago
I should add that Java is required to use the navigation menu (which is
essential for their internet banking).

For those interested I can tell you that on this page (in Swedish)

http://taz.vv.sebank.se/cgi-bin/pts3/pow/index.asp?ss=/pow/Kundservice/loggain.htm

they have a Q and A that reads (roughtly):

Q: Does the internet office work with Mozilla?
A: Yes, with Mozilla 0.9.4 and later for PC, Mac and Linux.

I'm resolving this baby fixed!
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 42

16 years ago
Verified fixed with 2002-01-16-08. 
Status: RESOLVED → VERIFIED

Comment 43

16 years ago
The QA Contact for Europe: West has changed to
brantgurganus2001@cherokeescouting.org.  If there is a reason for you to stay as
the QA Contact, feel free to change back.
QA Contact: caillon → brantgurganus2001
move...
Component: Europe: West → Other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.