[OS.File] Add an API for filesystem event notification (ie. inotify, filewatcher...)

RESOLVED DUPLICATE of bug 958280

Status

()

Core
Networking: File
--
enhancement
RESOLVED DUPLICATE of bug 958280
7 years ago
4 years ago

People

(Reporter: cedricv, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
This is a feature currently missing in the platform that would be quite useful.

Eg. for bug 671982
(Reporter)

Updated

7 years ago
Summary: (JSFileAPI) Add an API for filesystem events (inotify, filewatcher...) → (JSFileAPI) Add an API for filesystem event notification (ie. inotify, filewatcher...)
Assignee: general → nobody
Severity: normal → enhancement
Component: JavaScript Engine → Networking: File
QA Contact: general → networking.file
Summary: (JSFileAPI) Add an API for filesystem event notification (ie. inotify, filewatcher...) → [OS.File] Add an API for filesystem event notification (ie. inotify, filewatcher...)
It may be possible to implement this:
- under Linux, with inotify;
- under MacOS and BSD with kqueue;
- under Windows with FindFirstChangeNotification/FindNextChangeNotification.
Doug, David,
I assume this feature will be useful for the Media Storage API?
I think this is generally lower-level than the Media Storage API, but I would be glad if we could use it somewhere in the implementation of that API.
All this work is getting done elsewhere.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 958280
No longer blocks: 671982
You need to log in before you can comment on or make changes to this bug.