Closed Bug 707964 Opened 8 years ago Closed 8 years ago

Zombie compartment caused by cancelling an extension installation

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dbcooper.nz, Unassigned)

References

()

Details

(Whiteboard: [MemShrink:P3])

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111206 Firefox/11.0a1
Build ID: 20111206031117

Steps to reproduce:

(using moz central trunk nightly - 32bit on win7 64bit)

Navigate to http://www.readability.com/ and click the "download now" button to begin extension installation. At the prompt cancel the install and close the tab. Open a new tab and go to about:memory. 


Actual results:

There should be a readability.com compartment that won't go away. The compartment remains despite repeated use of the minimize memory usage button, further browsing (~ 30mins), and entering and exiting private browsing mode.


Expected results:

The readability.com compartment should have been released after closing the tab.
Hardware: x86_64 → x86
Confirmed by mozillazine builds forum member here:

http://forums.mozillazine.org/viewtopic.php?p=11532125#p11532125
Whiteboard: [MemShrink]
Yeah, looks like a dupe of bug 691537, although it confirms the problem on sites other than https://addons.mozilla.org
This is for an extension, not an addon, which could be different.

I can reproduce this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
bug 70507 is different, as it is just caused by visiting the website.  This is caused by attempting to install an extension.
I meant bug 707507, of course.
Probably not a dupe of 707507 - which is not contingent on starting an extension installation, and readability.com doesn't create a zombie compartment unless extension installation is initiated.
MemShrink:P3 because this is not a common case.
Whiteboard: [MemShrink] → [MemShrink:P3]
This is probably related to bug 691537, but this particular example occurs when the "we stopped this website from installing software!" permission dialogue comes up, before it gets to the point where it downloads the addons and asks if you want to actually install it.
I can't reproduce this using the steps from comment 0.  Actually, I had to select the "Sign up now" button and then provide a fake email address to get to where I could download it.

I also tried cancelling an installation of AdBlock Plus from https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/ and didn't get a zombie compartment from that, either.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.