java.lang.RuntimeException @ org.json.JSONException: End of input at character 0 of

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
P4
normal
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

See https://tbpl.mozilla.org/php/getParsedLog.php?id=7773095&tree=Birch - there is a lot of this repeated over and over:

12-06 08:14:24.427 E/GeckoConsole( 1690): [JavaScript Error: "this.browser.contentWindow is undefined" {file: "chrome://browser/content/browser.js" line: 1104}]
12-06 08:14:24.427 E/GeckoSoftwareLayerClient( 1690): Bad viewport description: 
12-06 08:14:24.427 W/System.err( 1690): java.lang.RuntimeException: org.json.JSONException: End of input at character 0 of 
12-06 08:14:24.427 W/System.err( 1690): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.updateViewport(GeckoSoftwareLayerClient.java:167)
12-06 08:14:24.427 W/System.err( 1690): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.endDrawing(GeckoSoftwareLayerClient.java:177)
12-06 08:14:24.427 W/System.err( 1690): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
12-06 08:14:24.427 W/System.err( 1690): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
12-06 08:14:24.427 W/System.err( 1690): 	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:452)
12-06 08:14:24.427 W/System.err( 1690): 	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:118)
12-06 08:14:24.427 W/System.err( 1690): Caused by: org.json.JSONException: End of input at character 0 of 
12-06 08:14:24.427 W/System.err( 1690): 	at org.json.JSONTokener.syntaxError(JSONTokener.java:446)
12-06 08:14:24.427 W/System.err( 1690): 	at org.json.JSONTokener.nextValue(JSONTokener.java:93)
12-06 08:14:24.427 W/System.err( 1690): 	at org.json.JSONObject.<init>(JSONObject.java:154)
12-06 08:14:24.427 W/System.err( 1690): 	at org.json.JSONObject.<init>(JSONObject.java:171)
12-06 08:14:24.427 W/System.err( 1690): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.updateViewport(GeckoSoftwareLayerClient.java:133)
12-06 08:14:24.427 W/System.err( 1690): 	... 5 more

This appears to be because get viewport is invoked while there is contentWindow.
that should be ".. while there is *no* contentWindow"
Also note that bug 704120 appears similar, but has a different root cause (different javascript error, which results in the same java-side exception). They might both be fixable by the same patch, if it is a general fix.
Priority: -- → P4
This isn't happening any more, closing bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.