Setting text style/property across multiple paragraphs inserts extra lines

VERIFIED FIXED in M8

Status

()

P3
normal
VERIFIED FIXED
20 years ago
17 years ago

People

(Reporter: cmanske, Assigned: buster)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Here's the HTML at the beginning of our default editor document:
<body>
<h2>Ender Editor Test Page</h2>
<p>This is a good place to add in html to aid in testing features
under
 development.  It's also a great place to not use latin.
</p>

Select from within the first line (before "test") and drag to the end of the
word "development". Click on the bold button on the toolbar.
Here's the HTML output:
<body>
<h2>Ender Editor <b null="null">Test Page</b></h2>
<b></b><b null="null"></b>
<p><b null="null">This is a good place to add in html to aid in testing features


under development</b>.  It's also a great place to not use latin.
</p>

(The extra CR/LF between "features" and "under" are exactly as shown in the
debug dump window.)
The extra <b></b> is the problem, but it only seems to happen when the original
selection crosses paragraphs that have different styles (I'm not sure if any
style differences trigger it, but I always seems to happen of one of the 2
lines has one of the Heading attributes.) It doesn't seem to happen if the
adjacent paragraphs have the same paragraph style.

The null="null" problem is a known problem, correct?
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M9
(Assignee)

Comment 1

19 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Target Milestone: M9 → M8

Comment 2

19 years ago
verified in 7/9 build.

Updated

19 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.