XUL CSS guide (better than what's currently out there)

RESOLVED FIXED in Future

Status

Documentation
Web Developer
--
enhancement
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Brian 'netdragon' Bober, Unassigned)

Tracking

unspecified
Future

Details

(URL)

(Reporter)

Description

17 years ago
There should be a document that explains how CSS works for XUL. It should have 
examples of CSS documents and screenshots of how it looks. This document should 
also explain how CSS works for each individual XUL element. It needs to list 
all the CSS attributes that work for each XUL element so people will have an 
easy way to tell if the CSS attributes people are trying to use work in XUL, 
and a list of attributes that don't work for each element and a list of ones 
that people are planning to implement. It can also list all the quirks of CSS 
for each XUL element. I think that Mozilla should be working towards having all 
possible CSS attributes work in XUL.

Comment 1

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Component: Style System → Web Developer
Ever confirmed: true
Product: Browser → Documentation
Version: other → unspecified
I do believe hyatt is working on such a creation. Reassigning QA to Ben since
he'll probably have to proof read the document once it's written.
Assignee: pierre → hyatt
QA Contact: ian → ben

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 3

15 years ago
resolve as fixed ?
Summary: [RFE]XUL CSS guide (better than what's currently out there) → XUL CSS guide (better than what's currently out there)

Comment 4

15 years ago
Sorry for spam, but there is no way to vore for this bug - so I just state my
"Mee Too" opinion here...

What currently exists in the Xulplanet is more or less OK but It could improve a
lot - by adding code samples and screenshots with results would be great - also
a nice testcase/demo (in a popup window?) wouldn't hurt...

Comment 5

13 years ago
Is this ever going to happen or is this a duplicate of bug 37512 ?

Updated

8 years ago
Assignee: hyatt → web.developer
QA Contact: bugs
No activity in 10 years. Closing. Please open new issues in the "Developer documentation" product to get issues on MDN's radar.

fwiw, seems like this ended up here https://developer.mozilla.org/en-US/docs/Skinning_XUL_Files_by_Hand
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.