The ifdefs in nsStackWalk.cpp are fairly hard to read and have duplicated code. The attached patch factors them to be a bit more readable. https://tbpl.mozilla.org/?tree=Try&rev=170707a6671b
Attachment #579393 - Flags: review?(ehsan)
Comment on attachment 579393 [details] [diff] [review] refactor the ifdefs in nsStackWalk.cpp This looks good, but to be honest I've never seen "defined" being used in a macro expansion (maybe that's just me), so let's ask dbaron to take a look at this as well.
Attachment #579393 - Flags: review?(ehsan) → review?(dbaron)
Comment on attachment 579393 [details] [diff] [review] refactor the ifdefs in nsStackWalk.cpp r=dbaron, except I don't like the names -- the "_WITH_UNWIND" naming seems easily confused with "HAVE__UNWIND_BACKTRACE", when they really mean different things. Maybe change X_WITH_UNWIND to NSSTACKWALK_SUPPORTS_X or something similar (for the three values of X)? Also, in the future, please include commit messages in patches posted for review.
Attachment #579393 - Flags: review?(dbaron) → review+
Assignee: nobody → respindola
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla12
You need to log in before you can comment on or make changes to this bug.