Last Comment Bug 708185 - Remove homepage preference
: Remove homepage preference
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
: P1 normal (vote)
: ---
Assigned To: Brian Nicholson (:bnicholson)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-06 22:22 PST by Brian Nicholson (:bnicholson)
Modified: 2016-07-29 14:21 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (9.76 KB, patch)
2011-12-06 22:22 PST, Brian Nicholson (:bnicholson)
doug.turner: review+
Details | Diff | Splinter Review

Description Brian Nicholson (:bnicholson) 2011-12-06 22:22:30 PST
Created attachment 579590 [details] [diff] [review]
patch

Since setting the homepage preference to anything other than the native about:home makes startup more difficult, we are (for now) getting rid of this preference.
Comment 1 Doug Turner (:dougt) 2011-12-06 22:25:35 PST
Comment on attachment 579590 [details] [diff] [review]
patch

This is fine.  Leave the string in the code.  I am not sure if we want to just keep it (maybe we want to add this back in the short term, and having it localized everywhere would be great).  File a followup to remove it and cc/ pike and mfinkle for input.
Comment 2 Axel Hecht [:Pike] 2011-12-08 12:21:34 PST
Not a friend to remove strings for bugs that have nothing to do with it, in this case, you're removing the language selector string? I'd leave them all untouched, and file bugs for the language string and the homepage strings independently.
Comment 3 Brian Nicholson (:bnicholson) 2011-12-08 13:44:41 PST
Filed bug 708806 and bug 708808 for string removal.

Landed: http://hg.mozilla.org/integration/mozilla-inbound/rev/27eb5d3609a1
Comment 4 Ed Morley [:emorley] 2011-12-09 06:54:42 PST
https://hg.mozilla.org/mozilla-central/rev/27eb5d3609a1
Comment 5 Carla Nadastean 2011-12-12 05:40:21 PST
Retested with:
Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111212 Firefox/11.0a1 Fennec/11.0a1
HTC Desire Z (Android 2.3)

Homepage preference is no longer listed in Preferences.
Verifying bug.

Note You need to log in before you can comment on or make changes to this bug.