Message filter apparently enabled via space-bar selection actually aren't

RESOLVED DUPLICATE of bug 481682

Status

RESOLVED DUPLICATE of bug 481682
7 years ago
7 years ago

People

(Reporter: cmpilato, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111115192257

Steps to reproduce:

Agent:  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.23) Gecko/20110921 Lightning/1.0b2 Thunderbird/3.1.15

While editing message filters today, I needed to quickly enable a whole batch of filters I'd previously disabled.  I noticed that I could use the arrow keys and space bar to navigate my list of message filters and toggle the "Enabled" checkbox, which was appealing as it was significantly easier to do than using the mouse to select each checkbox.


Actual results:

From a UI perspective, the apparent result of enabling/disabling message filters via the space bar is the same as when doing so with the mouse -- the checkboxes get "checked".  But upon closing and reopening the Message Filters dialog box, I discovered that any change made to the "Enabled" state of a filter using the mouse persisted, while those made using the space bar did not.


Expected results:

The "Enabled" UI should match the filter's enablement state, obviously.  Either the use of the space bar should *not* result in an apparent state change for the filter, or the state change made by the space bar should "take" and persist just as it would had I'd used the mouse.  (My preference is for the latter.)

Comment 1

7 years ago
(In reply to C. Michael Pilato from comment #0)
See bug 481682.

Comment 2

7 years ago
Thanks, Hashem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 481682
You need to log in before you can comment on or make changes to this bug.