Closed Bug 708277 Opened 8 years ago Closed 7 years ago

Remove deprecated PR_MAX() uses in Core

Categories

(Core :: General, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 785542

People

(Reporter: sgautherie, Assigned: prip)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [good first bug])

Attachments

(2 obsolete files)

There are at least a few leftovers in (non NSPR/NSS/etc) cpp files...
Attachment #580733 - Flags: review?(roc)
Assignee: nobody → thomas
Status: NEW → ASSIGNED
Flags: in-testsuite-
Keywords: checkin-needed
Backed out:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cf7878e0d886

For build failures on all platforms:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=7eb0c2f08597
https://tbpl.mozilla.org/php/getParsedLog.php?id=8105772&tree=Mozilla-Inbound
{
pldhash.cpp

e:/builds/moz2_slave/m-in-w32/build/xpcom/glue/pldhash.cpp(313) : error C3861: 'NS_MAX': identifier not found

e:/builds/moz2_slave/m-in-w32/build/xpcom/glue/pldhash.cpp(326) : error C3861: 'NS_MAX': identifier not found
}

Presume just missing the #include "nsAlgorithm.h"...
Target Milestone: mozilla12 → ---
Attachment #580733 - Attachment is obsolete: true
Attachment #583894 - Flags: review?(roc)
Comment on attachment 583894 [details] [diff] [review]
Bug 708277 - Replace PR_MAX with NS_MAX

/home/prip/Documents/ff/src/src/xpcom/glue/pldhash.cpp: In function ‘void PL_DHashTableSetAlphaBounds(PLDHashTable*, float, float)’:
/home/prip/Documents/ff/src/src/xpcom/glue/pldhash.cpp:327:59: error: no matching function for call to ‘NS_MAX(PRUint32, int)’
/home/prip/Documents/ff/src/src/xpcom/glue/pldhash.cpp:327:59: note: candidate is:
../../dist/include/nsAlgorithm.h:78:1: note: template<class T> const T& NS_MAX(const T&, const T&)
Attachment #583894 - Attachment is obsolete: true
Attachment #583894 - Flags: review?(roc)
(In reply to Thomas Prip Vestergaard [:prip] from comment #5)
> pldhash.cpp:327:59: error: no matching function for call to ‘NS_MAX(PRUint32, int)’

Try NS_MAX<PRUint32>(...) , as was done in
https://bugzilla.mozilla.org/attachment.cgi?id=574391&action=diff
Attachment #580733 - Attachment description: Bug 708277 - Replace PR_MAX with NS_MAX → Bug 708277 - Replace PR_MAX with NS_MAX [Backed out: Comment 3]
Attachment #580733 - Flags: checkin-
Am I wrong thinking this bug is a duplicate of Bug 785542 ?
(In reply to foudfou from comment #7)
> Am I wrong thinking this bug is a duplicate of Bug 785542 ?

Nope!
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 785542
You need to log in before you can comment on or make changes to this bug.