All users were logged out of Bugzilla on October 13th, 2018

Fennec (in Emulator) crashes on page load (java.lang.IllegalStateException: problem parsing line: null @ com.android.internal.net.NetworkStatsFactory.readNetworkStatsDetail(NetworkStatsFactory.java:313))

RESOLVED FIXED

Status

()

P5
critical
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: glind, Unassigned)

Tracking

({crash, reproducible})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash])

Attachments

(2 attachments)

Created attachment 579873 [details]
adb logcat log

using dec 7 nightly, seems to crash, urlbar doesn't respond to double-click.  (Lots of misbehaviour)

to reproduce:

1) wget "bit.ly/native11" -O native11 && adb install -rs native11
2) start 'nightly' in emulator
3) go to 'www.google.com'  (by clicking)
4) crash
I see two crashes in the log:

E/AndroidRuntime( 1015): java.lang.OutOfMemoryError
E/AndroidRuntime( 1015): 	at android.graphics.Bitmap.nativeCreate(Native Method)
E/AndroidRuntime( 1015): 	at android.graphics.Bitmap.createBitmap(Bitmap.java:605)
E/AndroidRuntime( 1015): 	at android.graphics.Bitmap.createBitmap(Bitmap.java:585)
E/AndroidRuntime( 1015): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.getBitmap(GeckoSoftwareLayerClient.java:202)
E/AndroidRuntime( 1015): 	at org.mozilla.gecko.GeckoApp$3.run(GeckoApp.java:602)
E/AndroidRuntime( 1015): 	at android.os.Handler.handleCallback(Handler.java:605)
E/AndroidRuntime( 1015): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/AndroidRuntime( 1015): 	at android.os.Looper.loop(Looper.java:137)
E/AndroidRuntime( 1015): 	at org.mozilla.gecko.GeckoAppShell$LooperThread.run(GeckoAppShell.java:153)
W/ActivityManager(  636):   Force finishing activity org.mozilla.fennec/.App


F/NetworkStats(  636): java.lang.IllegalStateException: problem parsing line: null
F/NetworkStats(  636): 	at com.android.internal.net.NetworkStatsFactory.readNetworkStatsDetail(NetworkStatsFactory.java:313)
F/NetworkStats(  636): 	at com.android.server.NetworkManagementService.getNetworkStatsUidDetail(NetworkManagementService.java:1223)
F/NetworkStats(  636): 	at com.android.server.net.NetworkStatsService.performPollLocked(NetworkStatsService.java:810)
F/NetworkStats(  636): 	at com.android.server.net.NetworkStatsService.updateIfacesLocked(NetworkStatsService.java:721)
F/NetworkStats(  636): 	at com.android.server.net.NetworkStatsService.updateIfaces(NetworkStatsService.java:699)
F/NetworkStats(  636): 	at com.android.server.net.NetworkStatsService.access$000(NetworkStatsService.java:128)
F/NetworkStats(  636): 	at com.android.server.net.NetworkStatsService$1.onReceive(NetworkStatsService.java:589)
F/NetworkStats(  636): 	at android.app.LoadedApk$ReceiverDispatcher$Args.run(LoadedApk.java:728)
F/NetworkStats(  636): 	at android.os.Handler.handleCallback(Handler.java:605)
F/NetworkStats(  636): 	at android.os.Handler.dispatchMessage(Handler.java:92)
F/NetworkStats(  636): 	at android.os.Looper.loop(Looper.java:137)
F/NetworkStats(  636): 	at android.os.HandlerThread.run(HandlerThread.java:60)
F/NetworkStats(  636): Caused by: java.io.FileNotFoundException: /proc/net/xt_qtaguid/stats: open failed: ENOENT (No such file or directory)
F/NetworkStats(  636): 	at libcore.io.IoBridge.open(IoBridge.java:406)
F/NetworkStats(  636): 	at java.io.FileInputStream.<init>(FileInputStream.java:78)
F/NetworkStats(  636): 	at java.io.FileReader.<init>(FileReader.java:42)
F/NetworkStats(  636): 	at com.android.internal.net.NetworkStatsFactory.readNetworkStatsDetail(NetworkStatsFactory.java:272)
F/NetworkStats(  636): 	... 11 more
F/NetworkStats(  636): Caused by: libcore.io.ErrnoException: open failed: ENOENT (No such file or directory)
F/NetworkStats(  636): 	at libcore.io.Posix.open(Native Method)
F/NetworkStats(  636): 	at libcore.io.BlockGuardOs.open(BlockGuardOs.java:98)
F/NetworkStats(  636): 	at libcore.io.IoBridge.open(IoBridge.java:390)
F/NetworkStats(  636): 	... 14 more
Severity: normal → critical
Keywords: crash
OS: Mac OS X → Android
Hardware: x86 → ARM
Whiteboard: [native-crash]
Keywords: reproducible
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Created attachment 581751 [details]
New log from 12/14.

(updated log to have exactly one run)
AaronMT seems to be able to run Fennec in the emulator.  I seem to have no success.  Why is this invalid?  I haven't had a native build that works on emulator for weeks, and if I am doing something wrong, I hope someone can correct me.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Not critical for shipping, but we should look into the reasons why this isn't working.
Priority: -- → P5
(In reply to Gregg Lind from comment #3)
> AaronMT seems to be able to run Fennec in the emulator.  I seem to have no
> success.  Why is this invalid?  I haven't had a native build that works on
> emulator for weeks, and if I am doing something wrong, I hope someone can
> correct me.

I had the same experience when I tried to install the latest Nightly build in the emulator. android.media process is force closed.
(In reply to Cristian Nicolae (:xti) from comment #5)
> (In reply to Gregg Lind from comment #3)
> > AaronMT seems to be able to run Fennec in the emulator.  I seem to have no
> > success.  Why is this invalid?  I haven't had a native build that works on
> > emulator for weeks, and if I am doing something wrong, I hope someone can
> > correct me.
> 
> I had the same experience when I tried to install the latest Nightly build
> in the emulator. android.media process is force closed.

I couldn't install Fennec on a emulated 4.0.3 device, but install worked fine for a 2.3.3 virtual device.

However, when I opened the app, the fennec process has stopped. Firefox Sync works as expected.

--
Virtual device details:

CPU: armv7
Target: Google APIs (API level 10)
Skin: WVGA800
SD Card: 512 Mb
hw.lcd.density: 240
vm.heapSize: 24
hw.ramSize: 512
(In reply to Cristian Nicolae (:xti) from comment #6)
> (In reply to Cristian Nicolae (:xti) from comment #5)
> > (In reply to Gregg Lind from comment #3)
> > > AaronMT seems to be able to run Fennec in the emulator.  I seem to have no
> > > success.  Why is this invalid?  I haven't had a native build that works on
> > > emulator for weeks, and if I am doing something wrong, I hope someone can
> > > correct me.
> > 
> > I had the same experience when I tried to install the latest Nightly build
> > in the emulator. android.media process is force closed.
> 
> I couldn't install Fennec on a emulated 4.0.3 device, but install worked
> fine for a 2.3.3 virtual device.
> 
> However, when I opened the app, the fennec process has stopped.
Fennec will only run in the 4.0.3 (armv7) emulator image.

I have it working fine in the Linux emulator.

Gregg - Are you using Windows? The log mentions not having GPU support, at which point we crash.

Updated

7 years ago
Summary: Fennec (in Emulator) crashes on page load. → Fennec (in Emulator) crashes on page load (java.lang.IllegalStateException: problem parsing line: null @ com.android.internal.net.NetworkStatsFactory.readNetworkStatsDetail(NetworkStatsFactory.java:313))
OOM listed as well; I think some of these crashes are resolved with the latest build.  Can you download the latest nightly (13a1) and see if you are crashing still?

Be sure to delete any previous downloads; for some reason I ended up having some weird issues when I still had some previous downloads.  I was however successfully starting on the ARMv7 emulator and able to go to www.google.com  It's pretty dog slow though.  I used API level 14.
Hi Gregg, May we get a status please?
I don't seem to be able to actually run the emulator successfully at the moment.  Clearly, using a connected physical device is a better development strategy!  If people see this working, then I accept the solution!
I'm not sure if I understand.  So even the emulator running is causing you an issue let alone running fennec in the emulator?

In the past, we have recommended using a connected physical device as a development strategy because the emulator is very slow.
I am currently unable to test whether the fixes are correct, because I am unable to success get FX onto the emulator to test it.  This is not a problem with Firefox, but with the poor quality of the emulator.  If you got it to run, I consider it resolved :)
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.