Disable Page Inspector menu items when TabView is open

RESOLVED WONTFIX

Status

Firefox Graveyard
Panorama
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: rc, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
STR:

From any given webpage...

1. Open Panorama aka TabView
2. (Tools) Web Developer > Inspect Cmd/Ctrl-alt/shift-I

We probably shouldn't be able to do that.

Side-effect(?): Inspector is active on the tab TabView was opened from.
(Reporter)

Comment 1

4 years ago
Latest behavior:

When opening Panorama and using the keyboard shortcut or menu, the Inspector opens but only when Panorama is closed and the currently-selected tab is made visible.
(Reporter)

Comment 2

4 years ago
Moving to Panorama. I think the real issue is that some menus and shortcuts are available while in that mode.
Component: Developer Tools: Inspector → Panorama

Comment 3

4 years ago
Possible duplicate of this bug https://bugzilla.mozilla.org/show_bug.cgi?id=621795
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.