HTTPS Post to browserid.org fails with SSL error

VERIFIED FIXED

Status

Web Apps
Soup
P1
blocker
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Harald, Assigned: Harald)

Tracking

Details

(Assignee)

Description

7 years ago
HTTP Post fails with exception.

12-07 17:07:14.433: D/SoupClient(5778): verifyId for https://apps-preview-dev.allizom.org from https://browserid.org/verify
12-07 17:07:15.063: W/SoupClient(5778): verifyId failed
12-07 17:07:15.063: W/SoupClient(5778): javax.net.ssl.SSLException: Not trusted server certificate
12-07 17:07:15.063: W/SoupClient(5778): 	at org.apache.harmony.xnet.provider.jsse.OpenSSLSocketImpl.startHandshake(OpenSSLSocketImpl.java:371)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.apache.http.conn.ssl.AbstractVerifier.verify(AbstractVerifier.java:92)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.apache.http.conn.ssl.SSLSocketFactory.createSocket(SSLSocketFactory.java:381)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:164)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.apache.http.impl.conn.AbstractPoolEntry.open(AbstractPoolEntry.java:164)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.apache.http.impl.conn.AbstractPooledConnAdapter.open(AbstractPooledConnAdapter.java:119)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:348)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:555)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:487)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:465)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.mozilla.labs.Soup.service.SoupClient.execute(SoupClient.java:136)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.mozilla.labs.Soup.service.SoupClient.executePost(SoupClient.java:99)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.mozilla.labs.Soup.service.SoupClient.verifyId(SoupClient.java:382)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.mozilla.labs.Soup.plugins.MozIdPlugin$3.run(MozIdPlugin.java:177)
12-07 17:07:15.063: W/SoupClient(5778): 	at android.os.Handler.handleCallback(Handler.java:587)
12-07 17:07:15.063: W/SoupClient(5778): 	at android.os.Handler.dispatchMessage(Handler.java:92)
12-07 17:07:15.063: W/SoupClient(5778): 	at android.os.Looper.loop(Looper.java:143)
12-07 17:07:15.063: W/SoupClient(5778): 	at android.app.ActivityThread.main(ActivityThread.java:5073)
12-07 17:07:15.063: W/SoupClient(5778): 	at java.lang.reflect.Method.invokeNative(Native Method)
12-07 17:07:15.063: W/SoupClient(5778): 	at java.lang.reflect.Method.invoke(Method.java:521)
12-07 17:07:15.063: W/SoupClient(5778): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:858)
12-07 17:07:15.063: W/SoupClient(5778): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:616)
12-07 17:07:15.063: W/SoupClient(5778): 	at dalvik.system.NativeStart.main(Native Method)
12-07 17:07:15.063: W/SoupClient(5778): Caused by: java.security.cert.CertificateException: java.security.cert.CertPathValidatorException: TrustAnchor for CertPath not found.
12-07 17:07:15.063: W/SoupClient(5778): 	at org.apache.harmony.xnet.provider.jsse.TrustManagerImpl.checkServerTrusted(TrustManagerImpl.java:168)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.apache.harmony.xnet.provider.jsse.OpenSSLSocketImpl.startHandshake(OpenSSLSocketImpl.java:366)
12-07 17:07:15.063: W/SoupClient(5778): 	... 22 more
12-07 17:07:15.063: W/SoupClient(5778): Caused by: java.security.cert.CertPathValidatorException: TrustAnchor for CertPath not found.
12-07 17:07:15.063: W/SoupClient(5778): 	at org.bouncycastle.jce.provider.PKIXCertPathValidatorSpi.engineValidate(PKIXCertPathValidatorSpi.java:149)
12-07 17:07:15.063: W/SoupClient(5778): 	at java.security.cert.CertPathValidator.validate(CertPathValidator.java:202)
12-07 17:07:15.063: W/SoupClient(5778): 	at org.apache.harmony.xnet.provider.jsse.TrustManagerImpl.checkServerTrusted(TrustManagerImpl.java:164)
12-07 17:07:15.063: W/SoupClient(5778): 	... 23 more
(Assignee)

Updated

7 years ago
Assignee: nobody → hkirschner
Severity: normal → blocker
Priority: -- → P1
(Assignee)

Comment 1

7 years ago
(Quick)fixed in https://github.com/mozilla/browserid/commit/4f4a600
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified Fixed
origin/HEAD 5e17ba3be6
Samsung Nexus S (Android 2.3.6)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.