Download toaster notification is displayed only for the first download

VERIFIED FIXED in Firefox 11

Status

()

Firefox for Android
General
P4
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Camelia Urian, Assigned: mfinkle)

Tracking

unspecified
Firefox 12
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox11 verified, firefox12 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111208 Firefox/11.0a1 Fennec/11.0a1
Device: Samsung Nexus S
OS: Android 2.3

Steps to reproduce:
1. Start application and go to ww.irs.gov
2. Download a file
3. Wait for download to finish
4. Download another file

Expected results:
 A system bar notification and a toaster notification is displayed "Download started..."

Actual results:
 A system bar notification is displayed, but toaster notification is not displayed.

Notes: User needs to restart Fennec for toaster notification to be displayed again.
(Assignee)

Updated

7 years ago
Priority: -- → P4
I don't see anything displayed in the system bar. Is this expected as of now?

The toaster notification is displayed every time, so I guess this bug has become worksforme?
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #1)
> I don't see anything displayed in the system bar. Is this expected as of now?

Any file download should create a "progress" system notification and when completed, should have a system notification allowing you to open the file.

> The toaster notification is displayed every time, so I guess this bug has
> become worksforme?

Yes
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Created attachment 585866 [details] [diff] [review]
patch

Found a code problem
Assignee: nobody → mark.finkle
Attachment #585866 - Flags: review?(margaret.leibovic)
(Assignee)

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Updated

7 years ago
Status: REOPENED → NEW

Updated

7 years ago
Attachment #585866 - Flags: review?(margaret.leibovic) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/60937143195c
status-firefox11: --- → affected
status-firefox12: --- → affected
https://hg.mozilla.org/mozilla-central/rev/60937143195c
Status: NEW → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
Comment on attachment 585866 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): unknown
User impact if declined: no notification for subsequent downloads
Testing completed (on m-c, etc.): baked
Risk to taking this patch (and alternatives if risky): none
Attachment #585866 - Flags: approval-mozilla-aurora?

Comment 7

7 years ago
Comment on attachment 585866 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora.
Attachment #585866 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/4f807d3438d0
status-firefox11: affected → fixed
status-firefox12: affected → fixed

Comment 9

7 years ago
Verified with:
Aurora 11.0a2 (2012-01-08) HTC Desire Z (Android 2.3)
Nightly 12.0a1 (2012-01-08) HTc Desire Z (Android 2.3)

Download toaster notification is displayed each time a file is downloaded.
Status: RESOLVED → VERIFIED
status-firefox11: fixed → verified
status-firefox12: fixed → verified
You need to log in before you can comment on or make changes to this bug.