Last Comment Bug 708613 - Move SplitView component in devtools/shared
: Move SplitView component in devtools/shared
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Cedric Vivier [:cedricv]
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on:
Blocks: 708213
  Show dependency treegraph
 
Reported: 2011-12-08 06:43 PST by Cedric Vivier [:cedricv]
Modified: 2012-01-28 16:04 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Move it. (41.00 KB, patch)
2011-12-08 07:21 PST, Cedric Vivier [:cedricv]
rcampbell: review+
Details | Diff | Splinter Review
Same patch. Rebased against tip. (40.05 KB, patch)
2012-01-19 06:40 PST, Cedric Vivier [:cedricv]
no flags Details | Diff | Splinter Review
Add missing module install in shared/Makefile... (40.73 KB, patch)
2012-01-19 20:41 PST, Cedric Vivier [:cedricv]
rcampbell: review+
Details | Diff | Splinter Review

Description Cedric Vivier [:cedricv] 2011-12-08 06:43:05 PST
Currently in devtools/styleeditor but this is a generic UI module that we intend to reuse for Scratchpad (see bug 708213) and other tools.

Let's move in in shared/ then.
Comment 1 Cedric Vivier [:cedricv] 2011-12-08 07:21:31 PST
Created attachment 580036 [details] [diff] [review]
Move it.
Comment 2 Rob Campbell [:rc] (:robcee) 2011-12-12 06:25:31 PST
Comment on attachment 580036 [details] [diff] [review]
Move it.

+    content/browser/splitview.css                 (shared/splitview.css)
 *   content/browser/styleeditor.xul               (styleeditor/styleeditor.xul)
-    content/browser/splitview.css                 (styleeditor/splitview.css)

we should put this in content/browser/devtools/...

(and should probably move the scratchpad and associates there as well in a separate patch).
Comment 3 Paul Rouget [:paul] 2012-01-05 08:37:40 PST
Shouldn't we land this?
Comment 4 Rob Campbell [:rc] (:robcee) 2012-01-17 07:20:59 PST
probably!
Comment 5 Cedric Vivier [:cedricv] 2012-01-19 06:40:17 PST
Created attachment 589853 [details] [diff] [review]
Same patch. Rebased against tip.
Comment 6 Rob Campbell [:rc] (:robcee) 2012-01-19 07:10:49 PST
https://hg.mozilla.org/integration/fx-team/rev/f96d6dd51d6c
Comment 8 Cedric Vivier [:cedricv] 2012-01-19 20:41:46 PST
Created attachment 590096 [details] [diff] [review]
Add missing module install in shared/Makefile...
Comment 9 Rob Campbell [:rc] (:robcee) 2012-01-20 10:45:48 PST
https://hg.mozilla.org/integration/fx-team/rev/50cd93681c9b
Comment 10 Rob Campbell [:rc] (:robcee) 2012-01-21 07:36:25 PST
https://hg.mozilla.org/mozilla-central/rev/50cd93681c9b
Comment 11 Rob Campbell [:rc] (:robcee) 2012-01-26 12:30:24 PST
Comment on attachment 590096 [details] [diff] [review]
Add missing module install in shared/Makefile...

[Approval Request Comment]
Regression caused by (bug #): New feature.
User impact if declined: Addon Compatibility will be affected*
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): It appears large, but it's really just a file move.

* About Addon Compatibility.

Fx11 is the first version of Firefox with this new feature. The SplitView.jsm file is already being used by an addon we are about to include in the browser. Not having this in its ultimate destination makes using this shared component more difficult. We only realized the potential of having this as a shared library later in the development of Firefox 12, hence our late request.

There really is negligible impact to landing this in aurora. Really.

Note You need to log in before you can comment on or make changes to this bug.