Firefox 8.0 or higher (like 9 beta 5 ) can't download some of linux files (tar)

RESOLVED INCOMPLETE

Status

()

Firefox
File Handling
RESOLVED INCOMPLETE
7 years ago
4 years ago

People

(Reporter: pooya, Unassigned, NeedInfo)

Tracking

9 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20140113])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111206234556

Steps to reproduce:

i try with all recent like firefox 8.0 or 9.0 beta , to download this link (which is tar.gz linux file ) 
http://a1240200.websitehostfree.com/DGS/ALL-ADDONS/Oscam-BIN_stable_6070.tar.gz



Actual results:

after download with firefox , file is corrupted , but if i use other browser like internet explorer or chrome or opera , after Downloading file is fine (not corrupted)


Expected results:

It should be downloaded fine same as other browser's could download that linke very well.
(Reporter)

Updated

7 years ago
Severity: normal → critical
Priority: -- → P1
That link now redirects to a secure hosting signup page. Do you have problems with -any- .tar.gz or just particular ones from that site?

Since other people seem to be able to download .tar.gz in general there's something odd with a particular site or maybe with your configuration. You might have better luck working with https://support.mozilla.com/ forums first so we can narrow down the relevant details.
Group: core-security
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 2

7 years ago
Well sorry , as u said , That link is now seems deleted (he frequently update latest version , upload new files) , but still there are some files in that host , which after firefox downloading , file become corrupted but with other browser this is not happened , please click on one of these files (download) to reporduce the bug :
http://a1240200.websitehostfree.com/DGS/ALL-ADDONS/


( Strange point is (as u also said) some of .tar.gz works with firefox! but except the link i sent u there are other links (diffrent host ) which has same state with firefox (corrupted).
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 3

7 years ago
ie at this moment there are 3 files in the link i have posted in my last post , try with one of them (and after reporducing , u could try with other browser ie Internet explorer ,...  , ie :
http://a1240200.websitehostfree.com/DGS/ALL-ADDONS/Oscam-stapi-r11.tar.gz
or
http://a1240200.websitehostfree.com/DGS/ALL-ADDONS/Oscam-stapi-PCSC-1.10rc_svn5932.tar.gz

or
http://a1240200.websitehostfree.com/DGS/ALL-ADDONS/daemon_camup-0.1.tar.gz

Comment 4

4 years ago
Can you still reproduce this bug? The domains doesn't exist anymore.
Severity: critical → normal
Component: General → File Handling
Flags: needinfo?(pooyair)
Priority: P1 → --
Whiteboard: [bugday-20140113]
Marking incomplete due to lack of answer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.