Last Comment Bug 708799 - WSEnable.exe.manifest: manifest authoring error c1010001
: WSEnable.exe.manifest: manifest authoring error c1010001
Status: RESOLVED FIXED
: regression
Product: MailNews Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows XP
: -- major (vote)
: Thunderbird 11.0
Assigned To: Mark Banner (:standard8, limited time in Dec)
:
:
Mentors:
Depends on:
Blocks: 707021
  Show dependency treegraph
 
Reported: 2011-12-08 12:54 PST by Markus Adrario [:Taraman]
Modified: 2011-12-12 23:24 PST (History)
5 users (show)
standard8: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Markus Adrario [:Taraman] 2011-12-08 12:54:20 PST
When Building com-central on WinXP, I get the following build error:

c:/mozilla-build/python/python2.6.exe /f/mozilla/comm-central/mozilla/config/pythonpath.py -I../../../mozilla/config /f/mozilla/comm-central/mozilla/config/expandlibs_gen.py nsMailWinSearchHelper.obj   > winsearch_s.lib.desc
make[7]: Entering directory `/f/mozilla/objdir-tb-release-cen/mail/components/se
arch/wsenable'
c:/mozilla-build/python/python2.6.exe /f/mozilla/comm-central/mozilla/config/pythonpath.py -I../../../../mozilla/config /f/mozilla/comm-central/mozilla/config/expandlibs_exec.py --uselist -- link -NOLOGO -OUT:WSEnable.exe -PDB:WSEnable.pdb -LARGEADDRESSAWARE -NXCOMPAT -DYNAMICBASE -SAFESEH  -DEBUG -DEBUGTYPE:CV -DEBUG -OPT:REF   f:/mozilla/objdir-tb-release-cen/mozilla/dist/lib/mozutils.lib WSEnable.obj ./module.res   kernel32.lib user32.lib gdi32.lib winmm.lib wsock32.lib advapi32.lib ole32.lib shell32.lib
Embedding manifest from /f/mozilla/comm-central/mail/components/search/wsenable/WSEnable.exe.manifest and WSEnable.exe.manifest

f:/mozilla/comm-central/mail/components/search/wsenable/WSEnable.exe.manifest :
manifest authoring error c1010001: Values of attribute "level" not equal in different manifest snippets.
make[7]: *** [WSEnable.exe] Error 31
make[7]: *** Deleting file `WSEnable.exe'
make[7]: Leaving directory `/f/mozilla/objdir-tb-release-cen/mail/components/search/wsenable'
make[6]: *** [libs] Error 2
make[6]: Leaving directory `/f/mozilla/objdir-tb-release-cen/mail/components/search'
make[5]: *** [libs] Error 2
make[5]: Leaving directory `/f/mozilla/objdir-tb-release-cen/mail/components'
make[4]: *** [libs_tier_platform] Error 2
make[4]: Leaving directory `/f/mozilla/objdir-tb-release-cen/mozilla'
make[3]: *** [tier_platform] Error 2
make[3]: Leaving directory `/f/mozilla/objdir-tb-release-cen/mozilla'
make[2]: *** [default] Error 2
make[2]: Leaving directory `/f/mozilla/objdir-tb-release-cen/mozilla'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/f/mozilla/objdir-tb-release-cen'
make: *** [build] Error 2

My mozconfig looks like this:
ac_add_options --enable-application=mail
ac_add_options --enable-calendar
ac_add_options --enable-extensions=venkman

ac_add_options --disable-debug
ac_add_options --enable-optimize
ac_add_options --disable-tests
ac_add_options --enable-libxul
ac_add_options --disable-accessibility
ac_add_options --disable-angle

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../objdir-tb-release-cen

When building comm-beta with the same config, it succeeds.
Comment 1 Kent James (:rkent) 2011-12-12 10:46:43 PST
I'm having the same problem (Windows 7) - any known workarounds?

My mozconfig:

ac_add_options --enable-debug
ac_add_options --enable-tests
ac_add_options --disable-optimize
ac_add_options --enable-chrome-format=flat
ac_add_options --enable-extensions=default
ac_add_options --enable-application=mail
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../tb-debug

rkent
Comment 2 Mark Banner (:standard8, limited time in Dec) 2011-12-12 10:55:55 PST
Sorry, meant to sort this earlier, I'm working on it now.
Comment 3 Mark Banner (:standard8, limited time in Dec) 2011-12-12 14:19:54 PST
I've backed out what I believe are the offending parts of bug 707021: http://hg.mozilla.org/comm-central/rev/bfb6c2f5a153

I've re-opened bug 707021 pending getting a revised fix that doesn't need the workaround.
Comment 4 Kent James (:rkent) 2011-12-12 15:58:39 PST
I can compile now, thanks.
Comment 5 Serge Gautherie (:sgautherie) 2011-12-12 19:30:39 PST
http://mxr.mozilla.org/comm-central/find?string=%2FWSEnable%5C.exe%5C.manifest%24
{
/mail/components/search/wsenable/WSEnable.exe.manifest

25       <ms_asmv3:requestedExecutionLevel level="requireAdministrator" uiAccess="false" />
}

There is only the expected file in the repository :-)


(In reply to Markus Adrario [:Taraman] from comment #0)
> Embedding manifest from
> /f/mozilla/comm-central/mail/components/search/wsenable/WSEnable.exe.
> manifest and WSEnable.exe.manifest
> 
> f:/mozilla/comm-central/mail/components/search/wsenable/WSEnable.exe.
> manifest :
> manifest authoring error c1010001: Values of attribute "level" not equal in
> different manifest snippets.

(Is it expected that there are two manifest files to embed?)
What is the value in these two files, especially in the objdir one?
Does a clobber fix this bug?
Comment 6 Serge Gautherie (:sgautherie) 2011-12-12 19:38:45 PST
(In reply to Mark Banner (:standard8) from comment #3)

> I've backed out what I believe are the offending parts of bug 707021:
> http://hg.mozilla.org/comm-central/rev/bfb6c2f5a153

Then, I assume '-MANIFESTUAC:NO' should also be added to MSVC 11 case, ftb.
Comment 7 Kent James (:rkent) 2011-12-12 23:24:24 PST
(In reply to Serge Gautherie (:sgautherie) from comment #5)

> Does a clobber fix this bug?

At least in my case, I also tried to recompile using an initially empty object directory, and I still had the issue before the fix of comment 3.

Note You need to log in before you can comment on or make changes to this bug.