Last Comment Bug 708838 - Fix js1_8/extensions/regress-422269.js to use findReferences instead of failing randomly
: Fix js1_8/extensions/regress-422269.js to use findReferences instead of faili...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: Jim Blandy :jimb
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on: 708261
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-08 14:05 PST by Jim Blandy :jimb
Modified: 2011-12-09 06:54 PST (History)
1 user (show)
jimb: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use findReferences instead of countHeap to make js1_8/extensions/regress-422269.js fail less randomly. (3.66 KB, patch)
2011-12-08 14:05 PST, Jim Blandy :jimb
jwalden+bmo: review+
Details | Diff | Splinter Review

Description Jim Blandy :jimb 2011-12-08 14:05:09 PST
Created attachment 580188 [details] [diff] [review]
Use findReferences instead of countHeap to make js1_8/extensions/regress-422269.js fail less randomly.

The SpiderMonkey test js/src/tests/js1_8/extensions/regress-422269.js fails
randomly, because it requires a certain object to be garbage-collected to
pass. With a conservative stack scanner, an object being retained is not
necessarily a bug, and in general, the engine makes no promises about which
objects it retains and which it doesn't.

The JavaScript shell's new findReferences function allows us to find all GC
edges referring to the object, and filter out ones we know to be benign.
This patch changes the test to use findReferences.
Comment 2 Ed Morley [:emorley] 2011-12-09 06:54:02 PST
https://hg.mozilla.org/mozilla-central/rev/db58cb437225

Note You need to log in before you can comment on or make changes to this bug.