Relative http: URL is auto-corrected

VERIFIED DUPLICATE of bug 22251

Status

()

VERIFIED DUPLICATE of bug 22251
18 years ago
16 years ago

People

(Reporter: bugzilla-mozilla-org, Assigned: darin.moz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Relative http: URLs (i.e. not including a domain name) are auto-corrected to
domain names.  For example (the "For Beginners" entry #1 from the referred
page), <http:what-is-loglan.html> should resolve to
<http://www.loglan.org/what-is-loglan.html>; instead, it resolves to
<http://what-is-loglan.html/>.

This is an invalid http URL according to RFC 2616, but I've seen it used many
places.  It is handled as the author desired by Netscape 4.76, which even prints
the fully-qualified "corrected" URL in the status bar.

Linux build 2001022405.  I suspect this is a duplicate, but can't come up with
Bugzilla search terms that will find it if so.
This is indeed a duplicate.  As you point out, such URIs are invalid per the
RFC.  This is for a reason -- the 'autocorrection' that NS 4.x does would break
certain completely valid URIs in non-hierarchical URI schemes.  See bug 22251
for details of why we do not do this autocorrection. The short of it is:

"The url syntax causing this bug was deemed a heinous abuse of the spec, and 
leads to numerous other inconsistencies, so we decided not to fix it. 
Perpetrators should adjust their pages."

(btw, I found the duplicate with a regexp search on "http:[^/]" in the summary....)

*** This bug has been marked as a duplicate of 22251 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.