Status

Cloud Services
Firefox Sync: Backend
RESOLVED DUPLICATE of bug 686468
7 years ago
6 years ago

People

(Reporter: dumitru, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-1-31])

(Reporter)

Description

7 years ago
Happened to me three times this evening. After manually hitting on "Sync now" it works.

Here are the logs:

1323398279931	Sync.Service	DEBUG	User-Agent: Firefox/9.0 FxSync/1.12.0.20111130065942.
1323398279931	Sync.Service	INFO	Starting sync at 2011-12-08 18:37:59
1323398279932	Sync.SyncScheduler	DEBUG	Clearing sync triggers.
1323398279933	Sync.Service	INFO	In sync().
1323398280262	Sync.Resource	WARN	Caught unexpected exception Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.responseStatus] Stack trace: _onComplete()@resource:///modules/services-sync/resource.js:327 < innerBind()@resource://services-sync/util.js:1071 < Channel_onStopRequest()@resource:///modules/services-sync/resource.js:553 in _onComplete.
1323398280262	Sync.Resource	DEBUG	Stack trace: _onComplete()@resource:///modules/services-sync/resource.js:327 < innerBind()@resource://services-sync/util.js:1071 < Channel_onStopRequest()@resource:///modules/services-sync/resource.js:553
1323398280262	Sync.Resource	DEBUG	Caught exception Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.visitResponseHeaders] Stack trace: _onComplete()@resource:///modules/services-sync/resource.js:362 < innerBind()@resource://services-sync/util.js:1071 < Channel_onStopRequest()@resource:///modules/services-sync/resource.js:553 visiting headers in _onComplete.
1323398280262	Sync.Resource	DEBUG	Stack trace: _onComplete()@resource:///modules/services-sync/resource.js:362 < innerBind()@resource://services-sync/util.js:1071 < Channel_onStopRequest()@resource:///modules/services-sync/resource.js:553
1323398280263	Sync.SyncScheduler	DEBUG	Next sync in 600000 ms.


1323405932516	Sync.Service	DEBUG	User-Agent: Firefox/9.0 FxSync/1.12.0.20111130065942.
1323405932516	Sync.Service	INFO	Starting sync at 2011-12-08 20:45:32
1323405932518	Sync.SyncScheduler	DEBUG	Clearing sync triggers.
1323405932518	Sync.Service	INFO	In sync().
1323405932819	Sync.Resource	WARN	Caught unexpected exception Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.responseStatus] Stack trace: _onComplete()@resource:///modules/services-sync/resource.js:327 < innerBind()@resource://services-sync/util.js:1071 < Channel_onStopRequest()@resource:///modules/services-sync/resource.js:553 in _onComplete.
1323405932819	Sync.Resource	DEBUG	Stack trace: _onComplete()@resource:///modules/services-sync/resource.js:327 < innerBind()@resource://services-sync/util.js:1071 < Channel_onStopRequest()@resource:///modules/services-sync/resource.js:553
1323405932819	Sync.Resource	DEBUG	Caught exception Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.visitResponseHeaders] Stack trace: _onComplete()@resource:///modules/services-sync/resource.js:362 < innerBind()@resource://services-sync/util.js:1071 < Channel_onStopRequest()@resource:///modules/services-sync/resource.js:553 visiting headers in _onComplete.
1323405932819	Sync.Resource	DEBUG	Stack trace: _onComplete()@resource:///modules/services-sync/resource.js:362 < innerBind()@resource://services-sync/util.js:1071 < Channel_onStopRequest()@resource:///modules/services-sync/resource.js:553
1323405932820	Sync.SyncScheduler	DEBUG	Next sync in 600000 ms.


1323406536070	Sync.Service	DEBUG	User-Agent: Firefox/9.0 FxSync/1.12.0.20111130065942.
1323406536070	Sync.Service	INFO	Starting sync at 2011-12-08 20:55:36
1323406536072	Sync.SyncScheduler	DEBUG	Clearing sync triggers.
1323406536072	Sync.Service	INFO	In sync().
1323406536593	Sync.Resource	WARN	Caught unexpected exception Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.responseStatus] Stack trace: _onComplete()@resource:///modules/services-sync/resource.js:327 < innerBind()@resource://services-sync/util.js:1071 < Channel_onStopRequest()@resource:///modules/services-sync/resource.js:553 in _onComplete.
1323406536593	Sync.Resource	DEBUG	Stack trace: _onComplete()@resource:///modules/services-sync/resource.js:327 < innerBind()@resource://services-sync/util.js:1071 < Channel_onStopRequest()@resource:///modules/services-sync/resource.js:553
1323406536593	Sync.Resource	DEBUG	Caught exception Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.visitResponseHeaders] Stack trace: _onComplete()@resource:///modules/services-sync/resource.js:362 < innerBind()@resource://services-sync/util.js:1071 < Channel_onStopRequest()@resource:///modules/services-sync/resource.js:553 visiting headers in _onComplete.
1323406536593	Sync.Resource	DEBUG	Stack trace: _onComplete()@resource:///modules/services-sync/resource.js:362 < innerBind()@resource://services-sync/util.js:1071 < Channel_onStopRequest()@resource:///modules/services-sync/resource.js:553
1323406536594	Sync.SyncScheduler	DEBUG	Next sync in 600000 ms.


I'm on the beta channel. Let me know if I can help further troubleshooting those.
Reporter, please test again on the latest firefox build or nightly build.  We need your sync log to determine the problem.

To set up sync logging, see:
https://philikon.wordpress.com/2011/06/13/how-to-file-a-good-sync-bug/
Whiteboard: [closeme 2012-1-31]
(Reporter)

Comment 2

6 years ago
I've upgraded my FF since I reported the bug (still on the beta channel), and I didn't notice the problem in a while.
Closing this out since it looks like it's fixed.
Thanks!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(correct resolution is WORKSFORME, unless we know precisely what changeset / server-tweak fixed this.)
Resolution: FIXED → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 686468
Component: General → Firefox Sync: Backend
QA Contact: general → sync-backend
You need to log in before you can comment on or make changes to this bug.