Closed Bug 708960 Opened 8 years ago Closed 7 years ago

Intermittent TEST-UNEXPECTED-FAIL | /tests/js/xpconnect/tests/mochitest/test_bug655297.html | Exited with code 1 during test run

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mwu, Unassigned)

References

Details

(Keywords: intermittent-failure)

Looks like a JS assertion at https://hg.mozilla.org/releases/mozilla-aurora/file/2453d5384fea/js/src/jscompartment.cpp#l465

Rev4 MacOSX Lion 10.7 mozilla-aurora debug test mochitests-4/5 on 2011-12-08 17:52:43 PST

https://tbpl.mozilla.org/php/getParsedLog.php?id=7840002&tree=Mozilla-Aurora

396 INFO TEST-START | /tests/js/xpconnect/tests/mochitest/test_bug655297.html
++DOMWINDOW == 87 (0x123895738) [serial = 292] [outer = 0x113e81e10]
Assertion failure: e.front().key.isString(), at /builds/slave/m-aurora-osx64-dbg/build/js/src/jscompartment.cpp:465
TEST-UNEXPECTED-FAIL | /tests/js/xpconnect/tests/mochitest/test_bug655297.html | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:00:35.455248
INFO | automation.py | Reading PID log: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmpAXSCQwpidlog
PROCESS-CRASH | /tests/js/xpconnect/tests/mochitest/test_bug655297.html | application crashed (minidump found)
Crash dump filename: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmp65Crr5/minidumps/044F7480-CE2B-4B82-A1A1-61FC1F8C51D6.dmp
Operating system: Mac OS X
                  10.7.2 11C74
CPU: amd64
     family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash address: 0x0

Thread 0 (crashed)
 0  XUL + 0x136f24
    rbx = 0x142f8280   r12 = 0x0cab5640   r13 = 0x14301a00   r14 = 0x00a297e8
    r15 = 0xffffffff   rip = 0x01136f24   rsp = 0x5fbf8a80   rbp = 0x5fbf8a80
    Found by: given as instruction pointer in context
 1  XUL + 0x4ae4e
    rip = 0x0104ae4f   rsp = 0x5fbf8a90
    Found by: stack scanning
Blocks: 438871
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.