Opening details for an add-on leaves keyboard focus on the add-on list

RESOLVED DUPLICATE of bug 616440

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 616440
7 years ago
7 years ago

People

(Reporter: Wladimir Palant, Unassigned)

Tracking

({access})

Trunk
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I've added Adblock Plus options directly to its Add-ons Manager page but noticed that this page isn't accessible by keyboard. Steps to reproduce:

1. Install a current Adblock Plus development build from https://adblockplus.org/en/development-builds#installation (any other extension with a scrollable details page in Add-ons Manager will do as well).
2. Restart browser.
3. Press Ctrl-Shift-A to open Add-ons Manager.
4. Click "More" in the Adblock Plus entry in the extensions list.
5. Press Page Down button.

Expected results:
The page scrolls down.

Actual results:
Nothing happens. In fact, if you press Down a few times and then Enter the details page for a different extension will open - the keyboard focus isn't on the page displayed but rather on the now invisible list of extensions.

Tested in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111208 Firefox/11.0a1 and Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0.
Sounds like a dupe of bug 616440.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 616440
You need to log in before you can comment on or make changes to this bug.