Focus ring shows around non-existing label for checkboxes in inline options

RESOLVED DUPLICATE of bug 669507

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 669507
8 years ago
8 years ago

People

(Reporter: gaubugzilla, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

8 years ago
Posted image Screenshot
Steps to reproduce:

1. Install a current Adblock Plus development build from https://adblockplus.org/en/development-builds#installation (any other extension with checkboxes in inline options).
2. Restart browser.
3. Press Ctrl-Shift-A to open Add-ons Manager.
4. Click "More" in the Adblock Plus entry in the extensions list.
5. Scroll down and click any of the checkboxes.

Expected result:
Keyboard focus moves onto the checkbox and is indicated in some meaningful way.

Actual result:
A focus ring appears to the right of the checkbox around its (empty) label. It isn't even recognizable as a focus ring, looks just wrong - see screenshot.

Reproduced in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111208 Firefox/11.0a1 and Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 669507
You need to log in before you can comment on or make changes to this bug.