Last Comment Bug 709010 - Add an empty components dir to b2g/
: Add an empty components dir to b2g/
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
:
:
Mentors:
Depends on:
Blocks: 709468
  Show dependency treegraph
 
Reported: 2011-12-09 04:12 PST by Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
Modified: 2012-01-30 05:25 PST (History)
5 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Create the empty components directory (3.11 KB, patch)
2011-12-09 04:12 PST, Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
cjones.bugs: review+
mounir: checkin+
Details | Diff | Splinter Review

Description Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-12-09 04:12:20 PST
Created attachment 580360 [details] [diff] [review]
Create the empty components directory

Fabrice need that for the camera application.
Comment 1 Mounir Lamouri (:mounir) 2011-12-14 02:44:32 PST
https://hg.mozilla.org/mozilla-central/rev/7c621c7bfea3
Comment 2 Benjamin Smedberg [:bsmedberg] 2011-12-14 04:05:53 PST
I would like to suggest that a "components" subdirectory was a mistake when we added it to toolkit/ and browser/ which we've been slowly trying to rectify, and that it would be better to just use direct subdirectories, e.g. b2g/camera. Death to deep and mostly meaningless directory structures, please!
Comment 3 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-12-14 04:20:30 PST
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #2)
> I would like to suggest that a "components" subdirectory was a mistake when
> we added it to toolkit/ and browser/ which we've been slowly trying to
> rectify, and that it would be better to just use direct subdirectories, e.g.
> b2g/camera. Death to deep and mostly meaningless directory structures,
> please!

Using direct subdirectories of the root folder sounds a bit overkill to me since the chrome, locales, theme, etc.. folders will be at the same level while they are semantically different.

What do you think of components/camera, components/comp1, component/comp3 instead?
Comment 4 Benjamin Smedberg [:bsmedberg] 2011-12-14 08:58:28 PST
Like components/ the name "chrome" is pretty much meaningless. We've used it poorly in the past to contain UI bits for lots of different functions. We should be organizing the code by function, not by the kind of file.

locales/ is segregated because that's how we manage source localization, not because that's a good structure for the code in general.

If we're going to have a bunch of builtin apps and you want to separate the apps from the core homescreen/UI code, then it might make sense to have b2g/apps/camera and b2g/apps/dialer and whatever else, but "components" could mean pretty much anything (in the past it has meant "stuff which is implemented as XPCOM components").
Comment 5 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-12-14 09:03:49 PST
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #4)

> If we're going to have a bunch of builtin apps and you want to separate the
> apps from the core homescreen/UI code, then it might make sense to have
> b2g/apps/camera and b2g/apps/dialer and whatever else, but "components"
> could mean pretty much anything (in the past it has meant "stuff which is
> implemented as XPCOM components").

That's still what it meant to me. When I said "Fabrice need that for the camera application" that's because of some xpcom he needs for it.

Note You need to log in before you can comment on or make changes to this bug.