Aftter a left-aligned image, a list's bullets (or numbers) overlap the image

RESOLVED DUPLICATE of bug 60593

Status

()

Core
Layout
--
trivial
RESOLVED DUPLICATE of bug 60593
17 years ago
17 years ago

People

(Reporter: Ken Harris, Assigned: karnaze (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14 i586; en-US; 0.8) Gecko/20010215
BuildID:    2001030205

After a left-aligned image, like <img src="mypic.png" align="left">,
a list (<ul> or <ol>) will have its bullets/numbers overlap the
image.

Reproducible: Always
Steps to Reproduce:
Nothing special.  Just load http://anu.samba.org/samba/survey/ or
any other page with a list after a left-aligned image.

Actual Results:  The bullets from an <ul> overlap the image.

Expected Results:  The bullets should be to the right of the image.

Found on Mozilla 0.8 (build 2001021503) (Linux); confirmed on
build 2001030205 (Win32).

Here's a simpler HTML snippet to demonstrate the problem.
(Insert your favorite image as image.png.)

<h1>Alignment trouble!</h1>

<img align="left" src="image.png">

Here's an unordered list.  Mozilla seems to eat the bullets.
<ul>
  <li>Item number 1
  <li>Item number 2
  <li>Item number 3
</ul>

Here's an ordered list.  Mozilla seems to eat the numbers, too.
<ol>
  <li>Item number 1
  <li>Item number 2
  <li>Item number 3
</ol>

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 60593 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.