Last Comment Bug 709272 - myapps.mozillalabs.com dashboard should be available offline
: myapps.mozillalabs.com dashboard should be available offline
Status: RESOLVED INVALID
devPreviewNonBlocker
:
Product: Web Apps
Classification: Other
Component: HTML (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Ian Bicking (:ianb)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 13:39 PST by Ian Bicking (:ianb)
Modified: 2015-09-09 13:05 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Ian Bicking (:ianb) 2011-12-09 13:39:59 PST
The application repository is essentially available offline, but the resources to access that repository are not.  That includes anything in /jsapi/, as well as /index.html and all the files the dashboard needs (images, JS, CSS).

We need a cache manifest for these files.
Comment 1 Dan Walkowski 2011-12-09 14:31:44 PST
Caching all the dashboard files is not too complicated, but the problem is the icons for apps. They are not saved, but fetched from the providers on launch.  Since they are from different domains, I'm not sure how or if they can be cached, since they are not known prior to launch.  I'd like to brainstorm how to make this happen.
Comment 2 Ian Bicking (:ianb) 2015-09-09 13:05:31 PDT
No longer exists

Note You need to log in before you can comment on or make changes to this bug.