Interactions with ZoneAlarm, inteferes with winshutdown/network settings

VERIFIED WORKSFORME

Status

Plugins Graveyard
Checkpoint Zonealarm
--
critical
VERIFIED WORKSFORME
18 years ago
2 years ago

People

(Reporter: Mike Ely, Unassigned)

Tracking

({qawanted, relnote})

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)
BuildID:    2001021508

After installing, reboot of the machine caused "True Vector" error message to 
appear with a close button.  After clicking the close button, all network 
settings were dumped.  System is now unstable during shutdown.This system (PII 
400, 128 ram, Award BIOS)connects to the internet via a Linksys NC100v2 nic.

Reproducible: Sometimes
Steps to Reproduce:
1.  Install a Linksys NC100v2 nic and get it configured to access the internet 
via cable modem.  Test the setup using a different browser, mail client, etc.
2.  Install ZoneAlarm 2.1.44.  Set security levels to "high" and allow 
appropriate programs access to the internet.  Retest setup as before.
3.  Install Mozilla build listed above, using installer.  Note that although 
not made explicit, the browser will not instantiate until after system reboot.
4.  Reboot system.  Test internet connection - should be gone.
5.  Reboot several times, until connection somehow reestablishes itself.  From 
here on, connection will be unreliable.
6.  Uninstall Mozilla.
7.  Uninstall TCP/IP protocol for the nic.
8.  Reboot system.  Install will autorun.  Reboot when prompted.
9.  Network configuration is now stable.

Actual Results:  See above.

Comment 1

18 years ago
I'm pretty sure this is already reported.

Comment 2

18 years ago
Possibly related to bug 48939?
Severity: critical → major

Comment 3

17 years ago
over to Networking for triage
(Reporter)

Comment 4

17 years ago
Sadly, I had to dump current version of Mozilla, as the system instability 
caused by the interaction between Mo and ZoneAlarm was unacceptable.  It may be 
of note that my isp uses dhcp, and I access the net via cable modem.  For the 
most part, the service they provide is rock-solid (they are the city utilities 
department), so I'm not sure this is the same problem as the Bell South DSL 
customer who gets irregular service.  It seems like it's an either-or 
proposition for me: either Mozilla or ZoneAlarm.  Considering the fact that 
without some kind of firewall, I'd just be free lunch for the script kiddies, I 
don't have a choice.  I eagerly await news about this bug, and am willing to do 
what I can in my limited way to help fix it.

Comment 5

17 years ago
trying that move again.
Assignee: asa → neeti
Component: Browser-General → Networking
QA Contact: doronr → tever

Comment 6

17 years ago
Possible Relnote...Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: relnote

Updated

17 years ago
Keywords: qawanted
Target Milestone: --- → mozilla1.0

Comment 7

17 years ago
Open Networking bugs, qa=tever -> qa to me.
QA Contact: tever → benc

Comment 8

17 years ago
Mother of god I just ran into this one and It is freakin ugly. I just installed
ZoneAlarm and at some point or another is BSoD taking the net connectio with it.
I rebooted, everything seemed fine until I tried accessing the
Net...nothing.....tried uninstalling ZoneAlarm nothing..Tried reinstalling
TCP/IP nothing....tried Uninstalling Network card and reinstalling it..Worked
fine.. This is *UGLY* i dont whose at fault here but this will kill your network
connection cold.
Severity: major → critical
OS: Windows ME → All

Comment 9

17 years ago
Unless someone can explain what the network behavior is an why this is a
problem, I'm going to leave this w/ browser-general. It probably is a networking
problem, but I don't have time to really dig into it unless it affects a lot of
people.

If you want me to look at this, but have no actual networking info, please vote
rather than post.
Assignee: neeti → asa
Component: Networking → Browser-General
QA Contact: benc → doronr

Comment 10

17 years ago
You say this all happens while using a cable modem? Often I reinstall windows,
and  it is a pain in the butt to get my nc100v2 to work. I tried everything,
then suddenly I decided to "reboot" the modem. Try unplugging and replugging
your cable modem while your computer is running and is still connected to the
cable modem. Works for me to get me connected, I dont know if it will apply to
this bug. Try it out.

Comment 11

17 years ago
Umm no this isnt a cable modem problem I am using a router with ADSL. And its
not a driver problem at all there is something really messy going on between
Mozilla & Zonealarm. As to network data I am not sure what is needed. If you
install Mozilla and then install ZoneAlarm on Windows 98...reboot and your
unable to use any net app.

Comment 12

17 years ago
reminds me of the old bug 28403

Comment 13

17 years ago
I tend to think this is a flaw in ZoneAlarm and not Mozilla, though the 
interaction is bad.  ZoneAlarm is known to have issues with many properly-
written applications, and it commonly caused BSoD for me.  I switched to Tiny 
Personal Firewall (also free for personal use) and have no problems.  The bug 
is undoubtedly ZoneLabs' and not Mozilla's, since how could a user-level 
application corrupt the network stack so badly?  Perhaps this should just stay 
unresolved and go in as a release note.
(Reporter)

Comment 14

17 years ago
Found via trial and error that the issues with ZoneAlarm take place when the 
Machine Debug Manager is active.  Disabling the MDM at startup solves all the 
associated problems, but not surprisingly causes other instabilities to 
manifest.  Looks like this one is definately Not a Mozilla problem.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 15

17 years ago
I'm inclined to believe this bug was/is the fault of other programs besides Moz.
I run ZoneAlarm, MDM and Moz all the time on my Win98SE box with no problems for
the past 2 years.
Product: Browser → Seamonkey

Comment 16

7 years ago
We're now tracking such bugs. This doesn't mean it's something we can fix, merely something we hope to be able to point vendors to so they can investigate. This is an automated message.
Assignee: asa → nobody
Status: RESOLVED → UNCONFIRMED
Component: General → Checkpoint Zonealarm
Ever confirmed: false
Product: SeaMonkey → Plugins
QA Contact: doronr → checkpoint-zonealarm
Resolution: INVALID → ---
Target Milestone: mozilla1.0 → ---
Version: Trunk → unspecified

Comment 17

7 years ago
Wow... 10 years later...
I think we can all be certain that Zone Alarm no longer has such issues. 
Re-resolving.
Maybe someone can "Close" these ancient bugs in light of FF4 and Gecko 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago7 years ago
Resolution: --- → INVALID

Comment 18

7 years ago
Verif. to get this off the radar.
Status: RESOLVED → VERIFIED
Resolution: INVALID → WORKSFORME
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.