Last Comment Bug 709400 - Would like to to override nsIInlineSpellChecker with javascript but [noscript] methods are blocking it.
: Would like to to override nsIInlineSpellChecker with javascript but [noscript...
Status: RESOLVED FIXED
[good first bug][mentor=ehsan]
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: 7 Branch
: x86_64 Windows 7
: -- normal (vote)
: mozilla12
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 16:16 PST by josh
Modified: 2012-01-05 09:38 PST (History)
3 users (show)
khuey: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Just do it (1013 bytes, patch)
2012-01-05 06:17 PST, Kyle Huey [:khuey] (khuey@mozilla.com)
ehsan: review+
Details | Diff | Splinter Review

Description josh 2011-12-09 16:16:14 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20110928 Firefox/7.0.1 SeaMonkey/2.4.1
Build ID: 20110928161145

Steps to reproduce:

I have a project that overrides nsIInlineSpellChecker in C++ code.
I would like to convert it to Javascript, but there are two [noscript] methods in nsIInlineSpellChecker that are blocking the creation of a Javascript object that can replace mozInlineSpellChecker successfully.

  [noscript] void init(in nsIEditor aEditor);
  [noscript] void cleanup(in boolean aDestroyingFrames);

Is [noscript] required on these methods?  Is it possible to remove it?
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-12-09 19:31:41 PST
Looks like it was this way in the initial checkin http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/editor/txtsvc/public/nsIInlineSpellChecker.idl&rev=1.1&root=/cvsroot

I don't see any reason why we can't drop [noscript] here.  Ehsan?
Comment 2 :Ehsan Akhgari 2012-01-04 13:54:00 PST
Yeah, we can do it.
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-01-05 06:17:20 PST
Created attachment 586053 [details] [diff] [review]
Just do it
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-01-05 09:38:48 PST
https://hg.mozilla.org/mozilla-central/rev/65983b0e4a76

Note You need to log in before you can comment on or make changes to this bug.