Firefox crashes on start-up must retry 7 to 8 times it even crashes when start new session is selected.

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Robert kinkead, Unassigned)

Tracking

({crash})

8 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0.1) Gecko/20100101 Firefox/8.0.1
Build ID: 20111120135848

Steps to reproduce:

Tried to open Firefox 


Actual results:

It crashed. when opening sometimes it will show a page for a few seconds then it crashes. When I click session restore some times it will restore the session but most times I have to hit session restore 7 or 8 times. Sometimes it will not open with session restore and I click on stare new session. It will sometimes start then, but occasionally I have to hit that 3 to 4 times to get FF to run.
Here is the crash report that was last submitted.
https://crash-stats.mozilla.com/report/index/bp-c87b5d25-8e0d-478a-a63b-0292f2111207   

ID: c87b5d25-8e0d-478a-a63b-0292f2111207
Signature: vFreeCFONTCrit

Signature	vFreeCFONTCrit
UUID	c87b5d25-8e0d-478a-a63b-0292f2111207
Date Processed	2011-12-07 13:44:53.340474
Uptime	1748
Last Crash	1.2 days before submission
Install Age	1.6 weeks since version was first installed.
Install Time	2011-11-26 23:07:23
Product	Firefox
Version	8.0.1
Build ID	20111120135848
Release Channel	release
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
Build Architecture	x86
Build Architecture Info	AuthenticAMD family 16 model 10 stepping 0
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x2e003c
User Comments	
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 05e0, AdapterDriverVersion: 6.14.12.8558
Has dual GPUs. GPU #2: AdapterVendorID2: 10de, AdapterDeviceID2: 05e0, AdapterDriverVersion2: 6.14.12.8558D3D10 Layers? D3D10 Layers-
D3D9 Layers? D3D9 Layers+
Processor Notes 	Priority Job
EMCheckCompatibility	True
Winsock LSP	MSAFD Tcpip [TCP/IP] : 2 : 1 : MSAFD Tcpip [UDP/IP] : 2 : 2 : MSAFD Tcpip [RAW/IP] : 2 : 3 : RSVP UDP Service Provider : 6 : 2 : RSVP TCP Service Provider : 6 : 1 : MSAFD NetBIOS [\Device\NetBT_Tcpip_{A8CB0329-FF9F-4169-9D7A-F4DADD692141}] SEQPACKET 3 : 2 : 5 : MSAFD NetBIOS [\Device\NetBT_Tcpip_{A8CB0329-FF9F-4169-9D7A-F4DADD692141}] DATAGRAM 3 : 2 : 2 : MSAFD NetBIOS [\Device\NetBT_Tcpip_{8513A6CD-F96E-4FCF-B490-C214F94B88C7}] SEQPACKET 0 : 2 : 5 : MSAFD NetBIOS [\Device\NetBT_Tcpip_{8513A6CD-F96E-4FCF-B490-C214F94B88C7}] DATAGRAM 0 : 2 : 2 : MSAFD NetBIOS [\Device\NetBT_Tcpip_{3F7E7FAA-FF67-48FB-A762-965BD2987F71}] SEQPACKET 1 : 2 : 5 : MSAFD NetBIOS [\Device\NetBT_Tcpip_{3F7E7FAA-FF67-48FB-A762-965BD2987F71}] DATAGRAM 1 : 2 : 2 : MSAFD NetBIOS [\Device\NetBT_Tcpip_{EB3154D6-AFA8-4B72-896E-FC69F7FDD7C1}] SEQPACKET 2 : 2 : 5 : MSAFD NetBIOS [\Device\NetBT_Tcpip_{EB3154D6-AFA8-4B72-896E-FC69F7FDD7C1}] DATAGRAM 2 : 2 : 2 : 

0 	gdi32.dll 	vFreeCFONTCrit 	
1 	gdi32.dll 	NtGdiGetTextCharsetInfo 	
2 	xul.dll 	gfxGDIFont::~gfxGDIFont 	gfx/thebes/gfxGDIFont.cpp:96
3 	xul.dll 	gfxGDIFont::`vector deleting destructor' 	
4 	xul.dll 	gfxFontCache::DestroyFont 	gfx/thebes/gfxFont.cpp:1017
5 	xul.dll 	gfxFontCache::NotifyExpired 	gfx/thebes/gfxFont.cpp:1005
6 	xul.dll 	nsExpirationTracker<gfxFont,3>::AgeOneGeneration 	obj-firefox/dist/include/nsExpirationTracker.h:210
7 	xul.dll 	nsExpirationTracker<gfxFont,3>::AgeAllGenerations 	obj-firefox/dist/include/nsExpirationTracker.h:234
8 	xul.dll 	gfxFontCache::~gfxFontCache 	obj-firefox/dist/include/gfxFont.h:655
9 	xul.dll 	gfxFontCache::`scalar deleting destructor' 	
10 	xul.dll 	gfxFontCache::Shutdown 	gfx/thebes/gfxFont.cpp:930
11 	xul.dll 	gfxPlatform::Shutdown 	gfx/thebes/gfxPlatform.cpp:337
12 	xul.dll 	nsComponentManagerImpl::KnownModule::~KnownModule 	xpcom/components/nsComponentManager.h:220
13 	xul.dll 	nsTArray<nsAutoPtr<nsComponentManagerImpl::KnownModule>,nsTArrayDefaultAllocator>::DestructRange 	obj-firefox/dist/include/nsTArray.h:1147
14 	xul.dll 	nsTArray<nsAutoPtr<nsComponentManagerImpl::KnownModule>,nsTArrayDefaultAllocator>::RemoveElementsAt 	obj-firefox/dist/include/nsTArray.h:875
15 	xul.dll 	nsComponentManagerImpl::Shutdown 	xpcom/components/nsComponentManager.cpp:1003
16 	xul.dll 	xul.dll@0xc6583f 	
17 	xul.dll 	ScopedXPCOMStartup::~ScopedXPCOMStartup 	toolkit/xre/nsAppRunner.cpp:1083
18 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3574
19 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:107
20 	firefox.exe 	firefox.exe@0x4043 	
21 	firefox.exe 	_RTC_Initialize 	
22 	mozcrt19.dll 	_initterm 	obj-firefox/memory/jemalloc/crtsrc/crt0dat.c:852
23 	firefox.exe 	firefox.exe@0x2087 	
24 	kernel32.dll 	GetCodePageFileInfo 	
25 	kernel32.dll 	BaseProcessStart 	
26 	firefox.exe 	firefox.exe@0x1cef


Expected results:

Firefox should have started up with my tabs intact so that I can browse.
(Reporter)

Comment 1

7 years ago
This started when I had to reinstall Windows XP. I am also having problems with Thunderbird
You seem to have a problem with fonts.
Do you have a broken font installed ?
Severity: normal → critical
Crash Signature: [@ vFreeCFONTCrit ]
Component: General → Graphics
Keywords: crash
Product: Firefox → Core
QA Contact: general → thebes

Updated

7 years ago
Duplicate of this bug: 711789

Comment 4

7 years ago
Maybe you should clear your font cache: http://www.ascendercorp.com/support/#cache
(Reporter)

Comment 5

7 years ago
How do you do that in FF and Thunder bird?
(Reporter)

Comment 6

7 years ago
How do you do that in FF and Thunder bird?

Never mind I found it in the link you gave me.

Comment 7

6 years ago
(In reply to Robert kinkead from comment #6)
> How do you do that in FF and Thunder bird?
> 
> Never mind I found it in the link you gave me.

Robert, did it work out?
Whiteboard: [closeme 2012-04-21]
(Reporter)

Comment 8

6 years ago
It worked in Thunderbird, but I am still having problems with FF. It still crashes and most of the time does not create a log. Sometimes it is so bad I have to open it in safe mode.
I even went through and reinstalled some 900 fonts and deleted over 2000 others to get back to what I had before the reinstall of XP. But it still is not working right.
Note that the crash report in comment #0 appears to be happening during _shutdown_, although this is described as a crash on _startup_. I wonder why the browser is immediately trying to shut down?

In any case, I'd suggest downloading a fresh copy of the current Firefox release, if you haven't already done so, as "Firefox/8.0.1" (from comment #0) is outdated. And try creating a fresh profile, to see if that affects it.
(Reporter)

Comment 10

6 years ago
I have tried that and, it did not correct the problem. I am now having to start in safe mode all the time. When it crashes now it does not even create a crash report.

Comment 11

6 years ago
So, you getting crashes on clean install, clean profile, no saved session and no crash report links in about:crashes ?
Whiteboard: [closeme 2012-04-21] → [closeme 2012-07-01]
(Reporter)

Comment 12

6 years ago
I was getting crashes on new (clean) install I received a crash report maybe 10 times since this was reported. However since the most recent update Version 13.0, I have not had any crashes.

Comment 13

6 years ago
Ok, glad that problem gone for you
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2012-07-01]
You need to log in before you can comment on or make changes to this bug.