Closed Bug 709515 Opened 8 years ago Closed 7 years ago

Long list of recipient names lacking scrollbar.

Categories

(Thunderbird :: Message Reader UI, defect)

9 Branch
x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mitra_lists, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

This is essentially the same as Bug #22312, but I've been asked to refile ...

If you recieve a message with a long list of recipients, and click on "75 more" then the list appears - with bad UI (as noted in Bug #511408). But that bug refers to the scrollbar problem from #22312 being fixed. 

Now ... the scrollbar doesn't appear at all - it looks like you can't access the rest of the list, although on a Mac 2-finger scrolling will get you there.
Which exact build are you using, and did you see it with an earlier build?
Do you see this in safe mode as well with all extensions disabled?
Component: Mail Window Front End → Message Reader UI
Keywords: regression
QA Contact: front-end → message-reader
With latest version 9 on Mac OS X 10.7.2, I see a scrollbar. (Note that I had set mailnews.headers.show_n_lines_before_more and removed this before my test).
Do you have set any prefs or do you use any extensions?
I'm using Junquilla, Show In Out; Test pilot for Thunderbird (don't know where that came from, *I* didn't add it); and View About;

I'm running 10.0a2 2012-12-07 

I'm not sure how to tell which preferences are set to non-default, if its the ones in Bold then the only relevant one appears to be:
mailnews.CustomHeaders  Return-Path: Sender: Reply-To: X-Spam-Level: Errors-To: Mailing-list: List-Id
I believe "mailnews.headers.show_n_lines_before_more" is default it is 1 (and not bolded).
(In reply to Mitra Ardron from comment #3)
> I'm running 10.0a2 2012-12-07 
OK, I've retestet with 10.0a2, but I also see the scrollbars in 10.0a2. Can you start your TB in safe-mode and see if it still happens?
(In reply to Mitra Ardron from comment #3)
> mailnews.CustomHeaders  Return-Path: Sender: Reply-To: X-Spam-Level:
> Errors-To: Mailing-list: List-Id

In theory, it is possible for the scrollbar to disappear if the height of the box is insufficient to accommodate at least the "up" and "down" buttons of it. With any custom header shown, the box height should increase.

Your example in attachment 580676 [details] shows the minimum From, Subject, and To headers. Does the scrollbar appear when more headings are shown?

Do you see a scrollbar with View > Headers > All?

> I believe "mailnews.headers.show_n_lines_before_more" is default it is 1

That preference setting should only have an effect /before/ the "more" button is clicked on and is ignored with View > Headers > All, thus shouldn't produce a scrollbar in any case.
WIth View-Headers-All, I get the scrollbar

In safe mode I don't get the scrollbar (except with View-Headers-All)
I'm still seeing this problem - anyone else confirmed it?
I can confirm it is NOT in this one:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120713 Thunderbird/14.0 ID:20120713141924

The scroll bar is there in 14/Windows.

Hope this helps.
(In reply to Mitra Ardron from comment #6)
> WIth View-Headers-All, I get the scrollbar
> 
> In safe mode I don't get the scrollbar (except with View-Headers-All)

how about with a new profile?
Flags: needinfo?(mitra_lists)
Scrollbar is now showing up i.e. now works for me so I'll close it unless someone else confirms the bug.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(mitra_lists)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.