Firefox should support onmousewheel event - consider again

RESOLVED DUPLICATE of bug 111647

Status

()

RESOLVED DUPLICATE of bug 111647
7 years ago
7 years ago

People

(Reporter: imanhp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.121 Safari/535.2




Expected results:

Please add/assign the onmousewheel to the equivalent DOMMouseScroll event. All other major browsers support this. It is kind of annoying after 10 years to still have to handle this case separately every time we code. This function is used more and more today on rich content webapps.
(Reporter)

Updated

7 years ago
OS: Windows 7 → All
Hardware: x86_64 → All
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 111647
mousewheel is somewhat deprecated (and the browsers which implement mousewheel, implement it in very different ways). All the browsers should implement wheel event.
You need to log in before you can comment on or make changes to this bug.