Realplayer plugin won't get registered

VERIFIED DUPLICATE of bug 56464

Status

()

Core
Plug-ins
VERIFIED DUPLICATE of bug 56464
17 years ago
17 years ago

People

(Reporter: Vesa Halttunen, Assigned: av (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2 i686; en-US; 0.9) Gecko/20010305
BuildID:    2001030508

After placing rpnp.so and raclass.zip from the RealPlayer 8 UNIX distribution in
the mozilla/plugins or ~/.mozilla/plugins directory Mozilla will not register
the Realplayer plugin at all. RealPlayer streams will not get played.

Reproducible: Always
Steps to Reproduce:
1. Copy rpnp.so and raclass.zip in $MOZILLA_FIVE_HOME/plugins/
2. Run Mozilla
3. Watch Mozilla not register the plugin
4. Try viewing an embedded Realvideo clip and you'll get a "missing plugin" dialog


Actual Results:  Mozilla did not register the Realplayer plugin and embedded
Real content was not shown.

Expected Results:  Mozilla should have registered the Realplayer plugin and
embedded Real content should have been shown.

This system is running Linux 2.4.2, glibc 2.2.1, XFree86 4.0.2. The plugin does
work fine in Netscape 4.75.
see bug 56464 -- apparently this is a compiler version issue...  are you using a
gcc >= 2.95 ?
More precisely, are you using a Mozilla compiled with gcc >= 2.95?  (like one of
the 2.95 builds from mozilla.org)
(Reporter)

Comment 3

17 years ago
I'm using a precompiled build from
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-i686-pc-linux-gnu.tar.gz.
Is there something I could do to get around this problem? I'm using gcc 2.95.2
here so I guess building Mozilla myself wouldn't help at all. I'm marking this
duplicate (couldn't find 56464 while searching since it was resolved) but I'd
still like to get some help with the issue =)

*** This bug has been marked as a duplicate of 56464 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
actually, it's only when you build mozilla with gcc >= 2.95 that you can get the
realplayer plugin to work...

So either building yourself or getting the -gcc2.95 builds from the mozilla.org
ftp site should do it.
(Reporter)

Comment 5

17 years ago
Oh, that way :)... Thanks!

Comment 6

17 years ago
verified duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.