Fails to handle large numbers in the input field for Alarm Settings.

RESOLVED DUPLICATE of bug 709727

Status

Calendar
Lightning Only
RESOLVED DUPLICATE of bug 709727
7 years ago
7 years ago

People

(Reporter: ebba, Unassigned)

Tracking

Lightning 1.0
x86_64
Windows 7

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.121 Safari/535.2

Steps to reproduce:

1. Launch Lightning v1.0 
2.Open "Tools>Settings>Lightning>Alarms"
3.Type more than 16 numbers in the input field for "Default time and alarm goes off before an event"


Actual results:

 When entering 17 or more numbers, the precision is lost, e.g. 1234567890123456789 becomes 1234567890123456768.
If 22 numbers are typed, the number gets reset to 1.


Expected results:

 Better handling, e.g. by not allowing more than 10 numbers?
(Reporter)

Updated

7 years ago
Component: General → Lightning Only
Product: Thunderbird → Calendar
Version: 1.0 → Lightning 1.0

Comment 1

7 years ago
Thanks for reporting the issue. However fixing this for tasks will fix it for events too. Therefore duplicating this on bug #709727.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 709727
You need to log in before you can comment on or make changes to this bug.