Firefox 9 beta 5 doesn't open web pages with native libraries on Fedora 14 i686

VERIFIED INVALID

Status

()

Firefox
General
--
major
VERIFIED INVALID
6 years ago
6 years ago

People

(Reporter: Artem S. Tashkinov, Unassigned)

Tracking

9 Branch
Firefox 9
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
In Firefox 9 beta 5 search box doesn't work - if I hit enter nothing happens.

It's a regression.

I've just downgraded to Firefox 9 beta 4 and it works again.

Error console is empty.
Does it also happen in Safe Mode with all extensions disabled?
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 2

6 years ago
(In reply to Henrik Skupin (:whimboo) from comment #1)

Yes, it doesn't work in safe mode either.
Given the beta 5 testplan those are the fixes which went into this beta release. Anthony or Juan, can we please investigate this issue as soon as possible?
Summary: [REGRESSION] Search bar has stopped working in Firefox 9 beta 5 → Search bar has stopped working in Firefox 9 beta 5
Artem, I tried Fx9b4 and Fx9b5 on Linux (64-bit) and I cannot see the difference in behavior. When I search using the search box on the top right (set to Google as the default search engine) I get results in both. If I do the awesome bar, it works too.

Is there any more information you can provide? Is this installation on a Ubuntu machine or other? Is the installation done through a special repo?
Do you see any errors in the Error Console when you reproduce the bug?
(Reporter)

Comment 6

6 years ago
I don't quite understand what's going on here, because it's not about the search bar, Firefox 9 b5 doesn't want to open any pages, i.e. when I start the browser, enter any address in the location bar, hit enter, absolutely nothing happens. It is of today.

Yesterday I was happily running b5 without any problems. The bug is so weird and so intermittent I have to close this bug report as invalid, because at first I need to find a way to reproduce it reliably.

My gut feeling tells me that it may have something with writing to places.sqlite, i.e. when the browser cannot update one its files, it silently fails to open a webpage.

OS: Fedora 14 i686, Firefox binaries from ftp.mozilla.org
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

6 years ago
OK, I've found the source of this bug.

After downloading Firefox from the official website, I always delete system libraries which come with it, which are:

libfreebl3.chk
libfreebl3.so
libnspr4.so
libnss3.so
libnssckbi.so
libnssdbm3.chk
libnssdbm3.so
libnssutil3.so
libplc4.so
libplds4.so
libsmime3.so
libsoftokn3.chk
libsoftokn3.so
libssl3.so

In turns out that Fedora 14 i686 supplied system libraries are no longer sufficient for proper Firefox functioning. It's kinda sad but I can live with that.
Summary: Search bar has stopped working in Firefox 9 beta 5 → Firefox 9 beta 5 doesn't open web pages with native libraries on Fedora 14 i686
Status: RESOLVED → VERIFIED
Keywords: regression, regressionwindow-wanted
Component: Search → General
QA Contact: search → general
You need to log in before you can comment on or make changes to this bug.