Copy-paste of link from URL bar after opening link from Facebook Android app gives redirect link, not the target

VERIFIED FIXED in Firefox 11

Status

()

Firefox for Android
General
P2
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: Brion Vibber, Assigned: cpeterson)

Tracking

unspecified
Firefox 12
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox11 fixed, firefox12 fixed, fennec11+)

Details

([MTD])

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111115183813

Steps to reproduce:

Followed a few links from Facebook (using Android Facebook app) opening them directly in Firefox nightly (20111212).

After loading, tap into the URL bar, tap-and hold for 'select all', then 'copy'.



Actual results:

A long ugly http://m.facebook.com/blah blah redirect URL is shown and copied.


Expected results:

The destination URL should have been copied.

Note that I can't reproduce this simply opening an HTTP redirect page such as http://leuksman.com/misc/redirect1.php within Fennec itself. It may be specific to opening from another app, or from the way the facebook redirectors work.
(Reporter)

Updated

5 years ago
Whiteboard: [MTD]

Updated

5 years ago
Assignee: nobody → cpeterson
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
OS: Linux → Android
Hardware: x86_64 → ARM
tracking-fennec: --- → 11+
(Assignee)

Comment 1

5 years ago
Created attachment 588273 [details] [diff] [review]
bug-709845-part-1-update-history-url.patch

Update the tab history's URL after a redirect.
Attachment #588273 - Flags: review?(doug.turner)
(Assignee)

Comment 2

5 years ago
Created attachment 588274 [details] [diff] [review]
bug-709845-part-2-fix-checkstyle-warnings.patch

Tab.java: Fix some checkstyle warnings about extra imports, missing access modifiers, trailing whitespace.
Attachment #588274 - Flags: review?(doug.turner)

Updated

5 years ago
Attachment #588273 - Flags: review?(doug.turner) → review?(mbrubeck)

Comment 3

5 years ago
Comment on attachment 588274 [details] [diff] [review]
bug-709845-part-2-fix-checkstyle-warnings.patch

next time just factor code cleanup in its own bug.
Attachment #588274 - Flags: review?(doug.turner) → review+
Attachment #588273 - Flags: review?(mbrubeck) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Comment 4

5 years ago
Created attachment 589246 [details] [diff] [review]
bug-709845-part-1-update-history-url-v1-rebased.patch

Rebased patch.

r=mbrubeck
Attachment #589246 - Flags: review+
(Assignee)

Comment 5

5 years ago
Created attachment 589248 [details] [diff] [review]
bug-709845-part-1-update-history-url-v1-rebased.patch

r=mbrubeck
Attachment #588273 - Attachment is obsolete: true
Attachment #589246 - Attachment is obsolete: true
Attachment #589248 - Flags: review+
(Assignee)

Comment 6

5 years ago
Created attachment 589250 [details] [diff] [review]
bug-709845-part-2-fix-checkstyle-warnings-v1-rebased.patch

Rebased patch. r=dougt
Attachment #588274 - Attachment is obsolete: true
Attachment #589250 - Flags: review+
(Assignee)

Comment 7

5 years ago
checkin-needed for rebased patches.
https://hg.mozilla.org/integration/mozilla-inbound/rev/d27ddb7ad032
https://hg.mozilla.org/integration/mozilla-inbound/rev/339d1d51af7a
status-firefox11: --- → affected
status-firefox12: --- → affected
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d27ddb7ad032
https://hg.mozilla.org/mozilla-central/rev/339d1d51af7a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
(Assignee)

Comment 10

5 years ago
Comment on attachment 589248 [details] [diff] [review]
bug-709845-part-1-update-history-url-v1-rebased.patch

[Approval Request Comment]
Regression caused by (bug #): None
User impact if declined: Bookmarked and copy/pasted URLs will grab the REDIRECTING page's URL, not the REDIRECTED TO page's URL.
Testing completed (on m-c, etc.): Landed on m-c yesterday.
Risk to taking this patch (and alternatives if risky): Tab history might mix up pages' URLs.
Attachment #589248 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 11

5 years ago
Comment on attachment 589250 [details] [diff] [review]
bug-709845-part-2-fix-checkstyle-warnings-v1-rebased.patch

[Approval Request Comment]
Regression caused by (bug #): None
User impact if declined: None because this patch correct code style warnings.
Testing completed (on m-c, etc.): Landed on m-c yesterday.
Risk to taking this patch (and alternatives if risky): Probably none.
Attachment #589250 - Flags: approval-mozilla-aurora?
Attachment #589248 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #589250 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/ab94103a2cdd
status-firefox11: affected → fixed
status-firefox12: affected → fixed
https://hg.mozilla.org/releases/mozilla-aurora/rev/07e692bcb977

Comment 14

4 years ago
Verified fixed on:
-build:  Firefox for Android 21.0a2 (2013-02-27), Firefox for Android 22.0a1 (2013-02-27)
-device: Samsung Galaxy Tab 10.1
-OS: Android 3.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.